sendmail not using mailertable...

Latest response


I'm having trouble getting my mailertable to work....
/etc/mail/ contains this line

    FEATURE(`mailertable', `hash -o /etc/mail/mailertable.db')dnl

    /etc/mail/mailertable contains this line        esmtp:[]
I ran these to "recompile" the settings...
makemap hash /etc/mail/mailertable.db < /etc/mail/mailertable

    m4 /etc/mail/ > /etc/mail/

    service sendmail restart
Then tried to send a test
$ mail -s "test email"
$ tail -f /var/log/maillog

    May  9 10:03:14 npsetl005 sendmail[27779]: p49E3EG0027777: to=<>, ctladdr=<root@npsetl005.domain.domain1.pri> (0/0), delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=120350, [], dsn=4.0.0, stat=Deferred: Connection refused by

We have this stupid problem on our internal network where DNS and MX records aren't really set up 100 percent correctly. Getting permission to change it, and test it are way beyond the scope of this question; So I just want sendmail to ignore what's in DNS and fire messages straight to our internal relay server (which works for dozens of other clients) - but it's not doing that. You can see that it's rewriting the addresses to because the parent * is a cname to (someone did this as a poor mans redirect. So if a user tries to go to a subdomain that doesn't exist, they go to the root website instead... I know. I know.)
What did I miss?