You must specify an organization for new units

Latest response

I've been doing testing on a Red Hat Developer subscription. I'm trying to set up RHEL 8 and all the sudden:

1) Registration during installation is a hard requirement
2) When I try to register I get "You must specify an organization for new units"

There is no further explanation and there is no block for organization. Anyone else run into this?

Responses

I hit this same problem yesterday while installing RHEL 8.2. This is funny because I did some RHEL 8.2 installs a couple weeks ago without this issue. Any idea how to get past it?

Hello Grant and Joe, This issue is faced if the registration is done using a user account that belongs to multiple organizations. Please refer to the known issue 'Registration fails for user accounts that belong to multiple organizations' in the release notes: https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8-beta/html-single/8.3_release_notes/index?lb_target=production#known-issue_installer-and-image-creation

solution is very poor

RH Customer Support chat referred met to RH Customer Service. RH Customer Service referred me back to RH Customer Support. Neither were able to tell me why my account has multiple organizations, what these organizations are, or how to get just one.

As a work-around, I have found that about 10% of the time, the RHEL 8.2 install GUI will not force registration as a hard requirement. I have made a iso from a rear backup of a working install then registered it with RH on the first boot. It is not a very elegant solution, but the best I have right now.

This is a piss poor way to introduce people to Redhat. Inconsistencies in YOUR database that STOP people from installing the software? Talk about "cutting off your nose to spite your face" The above link to the "solution" is a 404 now.

Same problem here, unable to solve

Anthonius it looks like everything synced up on the backend, and I was able to use my username password here to "register" .

One possible workaround for this is to use organization id + activation key instead of the "normal" username & password authentication.

If that's not possible in your case (IIRC it is not always possible to obtain an activation key easily) the best bet is to just skip registration at installation time - install from the DVD (that has all the repos on media, so no install time registration is needed to access them) and then register after the installation. The post-installation tools should AFAIK handle the multi-organisation accounts correctly already.

Unable to get around this, I am going to suggest to the customer to not use RHEL and explore other options due to installation issue that even the tech support people refuse to fix.

Red Hat is working to fix this, there is an open bug against this behavior: https://bugzilla.redhat.com/show_bug.cgi?id=1822880

From the release notes, the suggested work arounds are as follow: To work around this problem, you can either:

  • Use a different user account that does not belong to multiple organizations.
  • Use the Activation Key authentication method available in the Connect to Red Hat feature for GUI and Kickstart installations.
  • Skip the registration step in Connect to Red Hat and use Subscription Manager to register your system post-installation.

Hi Marc,

Thanks for the update.

Regards,

Jan Gerrit

It appears that the registration step is now mandatory in Anaconda - install will not begin without it. :(

First time installing RedHat for a school project, but man is my first experience horrible, multiple internal server errors while trying to register, needed to click the activation link in my email 3 (three!) times before it actually let me download the ISO. Now im installing it and i can't continue the installation without linking my redhat account, and I get this error while trying to log in.