How to enable broker web console when using internal artemis broker?

Latest response

Hi,

We have installed the activemq artemis broker but cannot see port 8161 starting, and no web configuration enabled.

Is there some manual/guide/documentation to use, cannot find any?

Versions:

Red Hat Fuse (7.6.0.fuse-760025-redhat-00001)

karaf@root()> version
4.2.6.fuse-760032-redhat-00001

karaf@root()> list
261 │ Active │  80 │ 2.13.0.redhat-00006             │ ActiveMQ Artemis AMQP Protocol
262 │ Active │  80 │ 2.13.0.redhat-00006             │ ActiveMQ Artemis HornetQ Protocol
263 │ Active │  80 │ 2.13.0.redhat-00006             │ ActiveMQ Artemis HQClient Protocol
264 │ Active │  80 │ 2.13.0.redhat-00006             │ ActiveMQ Artemis MQTT Protocol
265 │ Active │  80 │ 1.0.2.redhat-00001              │ ActiveMQ Artemis Native
266 │ Active │  80 │ 2.13.0.redhat-00006             │ ActiveMQ Artemis OpenWire Protocol
267 │ Active │  80 │ 2.13.0.redhat-00006             │ ActiveMQ Artemis Server OSGi
268 │ Active │  80 │ 2.13.0.redhat-00006             │ ActiveMQ Artemis STOMP Protocol

Tried to install webconsole feature but no success.

Also see in the fuse.log missing dependencies.

2020-08-31 16:04:49,924 | INFO  | FelixStartLevel      | o.a.k.s.i.a.o.CommandExtension   | 149 - org.apache.karaf.shell.core - 4.2.6.fuse-760032-redhat-00001 | Command registration delayed for bundle org.apache.karaf.web\
.core/4.2.6.fuse-760032-redhat-00001. Missing dependencies: [org.apache.karaf.web.WebContainerService

Can we change the file org.apache.activemq.artemis.cfg to point out webconfig?

config=file:${karaf.etc}/artemis.xml
name=local
domain=karaf
rolePrincipalClass=org.apache.karaf.jaas.boot.principal.RolePrincipal

From standard activemq artemis installation we have the bootstrap.xml:

<broker xmlns="http://activemq.org/schema">
   <jaas-security domain="activemq"/>

   <server configuration="file:/opt/amq-broker-7.2.3/amqbroker/etc//broker.xml"/>

   <!-- The web server is only bound to localhost by default -->
   <web bind="http://xxx.xxx.xxx.xxx:8161" path="web">
       <app url="redhat-branding" war="redhat-branding.war"/>
       <app url="artemis-plugin" war="artemis-plugin.war"/>
       <app url="dispatch-hawtio-console" war="dispatch-hawtio-console.war"/>
       <app url="console" war="console.war"/>
   </web>

</broker>

Is the web-tag possible to config in fuse-integrated installation?

Or should we enable/create a container for activemq in the Fuse Management Console to achieve the standard amq console through that container?
According to the user guide (Red_Hat_JBoss_Fuse-6.3-Management_Console_User_Guide):

ActiveMQ Tree view and details of running Apache ActiveMQ brokers. This page is available only
when you connect to a container with an ActiveMQ profile.

Please advice.

Best regards,
Fredrik

Responses

Hi,

Maybe the question should be more correct stated.

  1. Can we use the standard activemq consol running on port 8161 when hosting the broker within Fuse Karaf?
  2. If 1 N/A. How can we install the activemq-tab, we cannot see it. We only see Connect, JMX, Runtime, Logs, OSGI tabs in the menu. Missing the ActiveMQ-tab.

Best regards, Fredrik

I am afraid that running the Artemis broker inside Fuse Karaf is not a supported configuration. While you seem to have the core Artemis broker and most of the transports deployed in Karaf, the hawtio plugins for discovering the Artemis broker and offering the respective view is likely not deployed into your Karaf container.

Again to the best of my knowledge this is not a Red Hat supported setup. Its recommended to run the Artemis broker standalone and not inside Karaf. Then it comes with its own web console.

Thanks!!!

We have already one external standalone broker up-n-running, but wanted to consider to use everything hosted in fuse... just revert to our earlier solution then! :)

Best regards, Fredrik