Getting forbidden on all deployment

Latest response

Hi, i am trying to build an image to deploy my war with jboss EAP standalone directly in the container, so i have taken the https://github.com/jboss-developer/jboss-eap-quickstarts/tree/7.3.x/helloworld-ssl
app and build war from it, but when i deployed in my jboss container, everything goes well but when i try http://localhost:48080/helloworld-ssl/ i get forbidden without any explanation.

Where should i look ?

My base image is this one jboss-eap-7/eap73-openjdk11-openshift-rhel8

my docker file is not complicated i just take the war and copy it in standalone/deployments

when i go into the container and run deployments-info here is what i got :
NAME RUNTIME-NAME PERSISTENT ENABLED STATUS
helloworld-ssl.war helloworld-ssl.war false true OK

this is what i have tried so far, but with same result :
* add <welcome-file-list/> tag in the web.xml with index.html inside
* rebuild war multiple time
* change artifact id
* try hellorworld app (without ssl)
* change 185 user to jboss user

Really don't know what i am missing

Thank you

Responses

The war was corrupted :(

Hi Pierre Lochouarn,

Glad you got to the core of this issue. Hope you're able to use a backup valid copy of your war file.

Regards,
RJ