Missing package (genrb)

Latest response

I'm running RHEL 7.

I'm trying to install Quantum's LTFS drivers from source as I wish to experiment and modify their code.

However, when I run ./configure.sh, I (eventually) get:

checking whether to enable lin_tape or not (Linux Only)... no
checking for pkg-config... /usr/bin/pkg-config
checking for genrb... no
configure: error: genrb was not found

at which point the script exits.

When I run "yum search genrb" I get nothing. I've tried googling but the only results relate to ICU, which appears to already be installed on my system (at least in the form of libicu-50.2-3.el7.x86_64 & libicu-devel-50.2-3.el7.x86_64).

Am I missing something here? I mean, apart from genrb ;-)

Responses

yum install -y icu

Thanks for the reply. But when I enter:

yum install -y icu

I get:

Loaded plugins: langpacks, product-id, search-disabled-repos, subscription- : manager epel/x86_64/metalink | 26 kB 00:00
epel | 5.3 kB 00:00
rhel-7-server-rpms | 3.5 kB 00:00
(1/2): epel/x86_64/updateinfo | 1.0 MB 00:00
(2/2): epel/x86_64/primary_db | 6.9 MB 00:00
No package icu available. Error: Nothing to do

Any other suggestions?

Hello Jim C,

Red Hat Enterprise Linux 7 Server - Optional RPMs x86_64 7Server is the repository for the icu package.

Have you subscribed your server to it?

I am afraid the icu release from this repo may conflct with the release of libicu-50.2-3.el7.x86_64 which seem to be provided by EPEL

Regards,

Jan Gerrit