Shutdown Network Interface But It Still Listens and Connects

Posted on

Had an interesting thing happen this morning.

I am trying to stand up a new DNS server to replace our RHEL 6 DNS. I want to use the same IP address on the new DNS.

The new DNS server has two interfaces, one for internal traffic and the second to handle only DNS traffic on port 53 UDP/TCP.

I turned off the old DNS servers interface with ifcfg eth2 down.

I turned on the new DNS server's second interface with ip link set dev ens 224 up. It showed up but did not show the IP address. I had to issue systemctl restart network for the ip address to show up.

The new DNS was not resolving so after some troubleshooting. I decided to turn it off. I issued ip link set dev ens224 down and confirmed with ip a that the interface was reporting it was down.

I brought up the old DNS 's interface and confirmed it reported UP.

But DNS was still not resolving. When I ssh'd to the OLD DNS server I was connected to the NEW DNS server. I tried to ssh with the IP address and was connected to the NEW DNS server. But I confirmed again that ip a reported DOWN for the interface.

Can anyone tell me why the new DNS interface was still listening and connecting and I turned it off? I had to shutdown the server to regain connectivity to the old DNS server.