VLC not supported

Latest response

vlc media player not installing properly getting error as

(base) [root@localhost ~]# yum install vlc-core

Updating Subscription Management repositories.
Last metadata expiration check: 0:20:55 ago on Sat 08 Jun 2019 09:43:15 AM IST.
Error:
Problem: cannot install the best candidate for the job
- nothing provides libpng15.so.15()(64bit) needed by vlc-core-1:3.0.6-17.el7.x86_64
- nothing provides libpng15.so.15(PNG15_0)(64bit) needed by vlc-core-1:3.0.6-17.el7.x86_64
- nothing provides libgnutls.so.28()(64bit) needed by vlc-core-1:3.0.6-17.el7.x86_64
- nothing provides libgnutls.so.28(GNUTLS_1_4)(64bit) needed by vlc-core-1:3.0.6-17.el7.x86_64
- nothing provides liblua-5.1.so()(64bit) needed by vlc-core-1:3.0.6-17.el7.x86_64
- nothing provides libgnutls.so.28(GNUTLS_2_12)(64bit) needed by vlc-core-1:3.0.6-17.el7.x86_64
- nothing provides libgnutls.so.28(GNUTLS_3_0_0)(64bit) needed by vlc-core-1:3.0.6-17.el7.x86_64
- nothing provides libgnutls.so.28(GNUTLS_3_1_0)(64bit) needed by vlc-core-1:3.0.6-17.el7.x86_64
- nothing provides libva.so.1()(64bit) needed by vlc-core-1:3.0.6-17.el7.x86_64
- nothing provides libva-x11.so.1()(64bit) needed by vlc-core-1:3.0.6-17.el7.x86_64
- nothing provides libva-drm.so.1()(64bit) needed by vlc-core-1:3.0.6-17.el7.x86_64
- nothing provides libva.so.1(VA_API_0.33.0)(64bit) needed by vlc-core-1:3.0.6-17.el7.x86_64
- nothing provides libprotobuf-lite.so.8()(64bit) needed by vlc-core-1:3.0.6-17.el7.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Responses

Hi Ajinkya,

You can install VLC as a flatpak ... the flatpak package includes all dependencies ... here is what you have to do ... :)

flatpak remote-add --if-not-exists flathub https://dl.flathub.org/repo/flathub.flatpakrepo
flatpak install flathub org.videolan.VLC

Regards,
Christian

great!...thank you Christian!

You're welcome, Carlos ! :)