Problem Installing PgAdmin4 in RedHat Enterprise 7.6

Latest response

When i try to install PgAdmin4 (yum install pgadmin4) always throw the same error:

Error: Paquete: pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch (pgdg11)

Necesita: python-flask
Error: Paquete: pgadmin4-web-4.3-1.rhel7.noarch (pgdg10)

Necesita: mod_wsgi
Error: Paquete: pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch (pgdg11)

Necesita: python-blinker
Error: Paquete: pgadmin4-python-jinja2-2.8-9.rhel7.1.noarch (pgdg11)

Necesita: python-markupsafe
Error: Paquete: pgadmin4-web-4.3-1.rhel7.noarch (pgdg10)

Necesita: httpd
Error: Paquete: pgadmin4-python-alembic-0.9.7-3.rhel7.1.noarch (pgdg11)

Necesita: python-mako
Error: Paquete: python-paramiko-2.1.1-0.10.el7.noarch (epel)

Necesita: python2-pyasn1
Error: Paquete: python-paramiko-2.1.1-0.10.el7.noarch (epel)

Necesita: python-cryptography
Error: Paquete: pgadmin4-python-jinja2-2.8-9.rhel7.1.noarch (pgdg11)

Necesita: python-babel >= 0.8

Previously install EPEL (yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm)

How can i install those dependencies?

Responses

I believe you have dependency recolonization problem, try this and tell me if it runs ok:

yum install pgadmin3         # this will install the dependency 
yum install pgadmin4

almost work, now throw this:

Error: Paquete: pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch (pgdg10)

       Necesita: python-flask

Error: Paquete: pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch (pgdg10)

       Necesita: python-blinker

You need those two dependencies (python-flask, python-blinker) ,try this:

rpm -ivh http://mirror.centos.org/centos/7/extras/x86_64/Packages/python-flask-0.10.1-4.el7.noarch.rpm
rpm -ivh http://mirror.centos.org/centos/7/extras/x86_64/Packages/python-blinker-1.3-2.el7.noarch.rpm

The second worked correctly, but the first one throws this:

error: Error de dependencias:

python-itsdangerous es necesario por python-flask-1:0.10.1-4.el7.noarch

python-jinja2 es necesario por python-flask-1:0.10.1-4.el7.noarch

python-werkzeug es necesario por python-flask-1:0.10.1-4.el7.noarch

What is the output of this:

yum search python-flask

============================================================================================ N/S matched: python-flask ============================================================================================

pgadmin4-python-Flask-Mail.noarch : A Flask extension for sending email messages

pgadmin4-python-flask.noarch : A micro-framework for Python based on Werkzeug, Jinja 2 and good intentions

pgadmin4-python-flask-babel.noarch : Adds i18n/l10n support to Flask applications

pgadmin4-python-flask-babelex.noarch : Adds i18n/l10n support to Flask applications

pgadmin4-python-flask-gravatar.noarch : Small extension for Flask to make usage of Gravatar service easy

pgadmin4-python-flask-htmlmin.noarch : Flask html response minifier

pgadmin4-python-flask-login.noarch : User session management for Flask

pgadmin4-python-flask-migrate.noarch : SQLAlchemy database migrations for Flask applications using Alembic

pgadmin4-python-flask-paranoid.noarch : Simple user session protection

pgadmin4-python-flask-principal.noarch : Identity management for Flask applications

pgadmin4-python-flask-security.noarch : Simple security for Flask apps

pgadmin4-python-flask-sqlalchemy.noarch : Adds SQLAlchemy support to Flask application

pgadmin4-python-flask-wtf.noarch : Simple integration of Flask and WTForms

python-flask-admin.noarch : Simple and extensible admin interface framework for Flask

python-flask-babel.noarch : Adds i18n/l10n support to Flask applications

python-flask-cache.noarch : Adds cache support to your Flask application

python-flask-cache-doc.noarch : Documentation for the Flask-Cache module

python-flask-mako.noarch : Mako templating support for Flask applications

python-flask-openid.noarch : OpenID support for Flask

python-flask-rstpages.noarch : Adds support for reStructuredText to a Flask application

python-flask-script.noarch : Scripting support for Flask

python-flask-whooshalchemy.noarch : Whoosh extension to Flask/SQLAlchemy

python-flask-wtf.noarch : Simple integration of Flask and WTForms

python-flask-xml-rpc.noarch : Adds support for creating XML-RPC APIs to Flask

Try install this

yum install pgadmin4-python-flask.noarch

If successes do this:

yum install pgadmin4

This line yum install pgadmin4-python-flask.noarch Works perfect, apparently install everithing good But when try this yum install pgadmin4 Throws the same error

Error: Paquete: pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch (pgdg10)

       Necesita: python-flask

This will install all dependencies:

yum -y install https://download.postgresql.org/pub/repos/yum/11/redhat/rhel-7-x86_64/pgdg-centos11-11-2.noarch.rpm

Now we should proceed with no problem:

yum install pgadmin4 -y

Don't work, throws the same error

Error: Paquete: pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch (pgdg10)

       Necesita: python-flask

Try to install flask first:

yum clean dbcache
yum install python-flask

If there is an error, please show me the output of this:

yum search flask

throw this:

======================================================== N/S matched: flask ========================================================

pgadmin4-python-Flask-Mail.noarch : A Flask extension for sending email messages

pgadmin4-python-flask-babel.noarch : Adds i18n/l10n support to Flask applications

pgadmin4-python-flask-babelex.noarch : Adds i18n/l10n support to Flask applications

pgadmin4-python-flask-gravatar.noarch : Small extension for Flask to make usage of Gravatar service easy

pgadmin4-python-flask-htmlmin.noarch : Flask html response minifier

pgadmin4-python-flask-login.noarch : User session management for Flask

pgadmin4-python-flask-migrate.noarch : SQLAlchemy database migrations for Flask applications using Alembic

pgadmin4-python-flask-principal.noarch : Identity management for Flask applications

pgadmin4-python-flask-security.noarch : Simple security for Flask apps

pgadmin4-python-flask-sqlalchemy.noarch : Adds SQLAlchemy support to Flask application

pgadmin4-python-flask-wtf.noarch : Simple integration of Flask and WTForms

python-flask-admin.noarch : Simple and extensible admin interface framework for Flask

python-flask-babel.noarch : Adds i18n/l10n support to Flask applications

python-flask-cache.noarch : Adds cache support to your Flask application

python-flask-cache-doc.noarch : Documentation for the Flask-Cache module

python-flask-mako.noarch : Mako templating support for Flask applications

python-flask-openid.noarch : OpenID support for Flask

python-flask-rstpages.noarch : Adds support for reStructuredText to a Flask application

python-flask-script.noarch : Scripting support for Flask

python-flask-whooshalchemy.noarch : Whoosh extension to Flask/SQLAlchemy

python-flask-wtf.noarch : Simple integration of Flask and WTForms

python-flask-xml-rpc.noarch : Adds support for creating XML-RPC APIs to Flask

python2-fedora-flask.noarch : Python modules for flask applications authing to Fedora Account System

python2-flask-login.noarch : User session management for Flask

python2-flask-migrate.noarch : SQLAlchemy database migrations for Flask applications using Alembic

python2-flask-multistatic.noarch : A simple flask plugin to allow overriding static files

python2-flask-oidc.noarch : An openID Connect support for Flask

python2-flask-restful.noarch : Simple framework for creating REST APIs for Flask

python2-flask-sqlalchemy.noarch : Adds SQLAlchemy support to Flask application

pgadmin4-python-flask.noarch : A micro-framework for Python based on Werkzeug, Jinja 2 and good intentions

pgadmin4-python-flask-paranoid.noarch : Simple user session protection

python2-mimerender.noarch : RESTful HTTP Content Negotiation for Flask, Bottle, etc.

Sorry for this late, try this:

yum erase pgadmin*
yum install pgadmin4 -y

If the above didn't work you, than I would recommend you to follow this article. But first you have to clean things before.

yum erase pgadmin*

Hi no problem :), i try but throws the same error Error: Paquete: pgadmin4-python-flask-principal-0.4.0-14.rhel7.1.noarch (pgdg10)

       Necesita: python-flask

yum can be configured to try to resolve such errors by temporarily enabling

disabled repos and searching for missing dependencies.

To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf

BUT... aparentlty i FINALLY could install pgadmin, I made the modification in "search-disabled-repos.conf" in /etc/yum/pluginconf.d/search-disabled-repos.conf Chage the flag "'notify_only=1" to "'notify_only=0" and then ran "yum install pgadmin4 -y" and then install all the dependencies, now i need to configure pgadmin

THANKS FOR THE HELP!!

OK great, glad I participate.