Nothing but problems installing and running RHEL 7 (developer subscription)

Latest response

I just want to put up my hand and flag the latest rhel 7 image, procured through the developer program, as well as some other system considerations that I think many people will agree are sub par.

Full disclosure: I am making the move across from Arch Linux in anticipation of enlisting enterprise grade support, but after spending two days trying to get this working I am becoming increasingly skeptical of any ROI.

To be clear, this post is merely a professional courtesy. I am not looking for any feedback or assistance. I am only here to raise some issues and leave them with the community to raise any bugs they feel are worthy. I simply cannot afford to invest any more time investigating or becoming familiar with this system.

Here are the issues I have faced during and after installation. All of the issues listed under 'Installer bugs' have been noted across various installation media and target systems.

Installer bugs:

-installer hang: when selecting packages to install in the 'software selection' section, during the installation when trying to create a user and also when selecting the "Network and Connections" section. I have had to force reboot about 10 times and yes: I tried different installation media and target systems.

-anything other than a very basic GUI install (i.e. select "server with GUI" and "KDE" package) causes system bugs as follows:

-login loop in GUI for user created during 'initial setup' (post install reboot). When logging in through CLI in a second tty, I get the error "cannot create folder /home/(username) Permission Denied" (username is obfuscated here for security). Yet I made this user the admin and checked to make sure it was part of the wheel group.

-desktop hang and freeze after login. It will start loading the desktop, icons begin appearing and then it will freeze, hard reboot required.

Other:

-default desktop environment is set to GNOME, even though KDE was the only selected environment during installation. If you don't change it then login just hangs and never loads a desktop env. Why is it the default when it wasn't installed?

-no option for GNOME desktop environment during installation

-no option for mirrored displays in KDE

General System considerations:

-No public URL for boot.iso and no mention anywhere of this fact. This issue has been brought up before and someone did raise a bug report, however it has not been addressed. I don't mind if I have to self-host a network install, but you guys are the ONLY distro that does not have a public URL for a network install. So it follows that this needs to be made very obvious to the user upon downloading an image. As it stands I have wasted a day re-downloading the full image, not cool at all.

-License acceptance for installed product hidden within the online login. Why is the license agreement hidden? I accept during install and got my iso from my online account, yet it wasn't until logging in with my phone that an agreement showed up. Further I couldn't register my subscription manager until this step taken. Confusing.

Issues with online site:

-forums are not made mobile friendly, cannot select an item for "Product" field. Reproducible across Android and OSX devices.

-logging in causes redirect loop, experienced on Android and Linux. Had to dig up an old Windoze machine to write this post.

Observations and final assessment:

I have spend the better part of two days trying to work my way around this poorly documented and confusing installation. When it finally installed properly, loading time was extremely slow and would often freeze after login. I have an abundance of system resources and other OS' work just fine, so it's not a hardware issue.

To me these things represent some fundamental flaws, that undermine the positive aspects of your ostensibly great and powerful system offering. I love your PaaS, but this was plain awful. It has been a wholly disappointing experience, to the point where I have gone from assuming Red Hat to be of sound quality and high value, to having zero confidence in this OS as a client-side system.

From where I am standing, there is no advantage using this system as a client-side desktop over any other Linux distro or indeed the dreaded Windoze. There is just as much integration with enterprise grade development suites as any other system. Even if I was using this to run servers, I would rather use a headless Debian or Arch flavour, at least then it would work and I would have some semblance of control.

My advice would be to focus on server technologies, rather than trying to over-extend your product offering into client-side desktops. If you retain the desire to make these desktop offerings then they need to be much better, more stable and actually usable, end of.

Anyway moving forward I would rather (and will) hire people that can configure and maintain their own Arch Linux or Ubuntu systems, than risk these problems with Red Hat as a product.

That is all. Peace.

Responses

Hello Aidan, I am sorry to hear of your troubles. I raised an internal bug some time ago "Explain bootstrap ISO requires own repo of packages" and I have just upped its priority and linked back to this discussion.

Hi Aidan,

Did you by chance use the beta version 7.6? Sadly that is the default when downloading. If you are attempting to load Linux and get an initial consistent load, try 7.5 (as I type this Oct 3, 2018 it is the most current non-beta version of RHEL)

Sorry to hear you had such a bad experience. I routinely use the Developer Suite, which is really just 7.5 (or non-beta current version of) Red Hat Enterprise Linux Server and I never experience that sort of set of issues. It is the same installation ISO file as the production version (identical ISO file, no difference). The only difference is the support. I also use the production version routinely and do not have these issues.

I routinely load Linux (even today I had a training day where 15 of our new admins load it by hand for experience, and it worked in all cases today). Now I see you did have a bad experience, and believe it happened, but I bring this up to let you know what you experienced is largely atypical.

At Developers.redhat.com there is a graphical photo guide that leads one step-by-step, I'm not sure if that helped you or not. https://developers.redhat.com/products/rhel/hello-world/#fndtn-macos

Did you happen to check the sha256sum of the ISO file? If it went that poorly, it's worth checking. https://access.redhat.com/downloads/content/69/ver=/rhel---7/7.5/x86_64/product-software

Kind Regards,

RJ

Hi Aidan,

I can completely confirm what RJ said, I've never had any sort of trouble like the problems you've described. Most probably you've been running into a graphics hardware related issue - I have supported many users with a similar kind of problem. Please boot the installation medium with the parameter nouveau.modeset=0 (in case you have a NVIDIA GPU) or radeon.modeset=0 (in case you have an AMD GPU). If that also leads to issues, boot with the parameter nomodeset. I am sorry too that you had such a bad experience with installaing RHEL so far, please give it another try (only in case you want of course) - now I wish you better luck. :)

Regards,
Christian