Glance images stuck in "saving" state

Posted on

Hi,

I have a OSP10 system installed/deployed with two compute servers and one controller server.

I am having problems getting images to save and instances to launch with this configuration.

The strange thing is that if I just deploy with a single compute node, saving and launching is fine. I have tried both compute nodes separately and both work just fine. the controller node is the same. I even tried deploying with a single compute and then growing to a second. I verified that I could import an image with one node, but when I added the second it get stuck in saving.

I looked at the output of /var/log/glance on the controller node and don't see anything. strange. There are no errors. /var/log/glance on the compute nodes is empty so It looks like all the work is done by the controller.

there is one comment about the file being zero length. but it is the same file that works when only one compute server is present.

any thoughts/suggestions would be greatly appreciated.

I have inluded the glance date. If anything yes would help diagnose this. please let me know.

Tim

Attachments