Can not get updates

Latest response

NOTE: I've listed 'redhat enterprise linux for real time' as the OS since I can't find an entry for standard Red Hat linux (7.4 beta)
In any case, I see that /etc/yum.repos.d to be empty except redhat.repo files which has no meaninful contents.

yum update - gives me this info

Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
: manager
This system is registered with an entitlement server, but is not receiving updates. You can use subscription-manager to assign subscriptions.
There are no enabled repos.
Run "yum repolist all" to see the repos you have.
To enable Red Hat Subscription Management repositories:
subscription-manager repos --enable
To enable custom repositories:
yum-config-manager --enable

--- Any of the commands above are not useful to me. I have used subscription-manager to register the product.
Can someone please help? After tiring to do update -really- i've chosen to create post here. Thanks in advance.
PS : not sure if it's worth metioning, I am only trying out Redhat through their developer program - and am not a paying customer.
I've tried copying files yum.repos.d, but no avail.
Only I needed to try - which I haven' t yet - is to use server dvd as source of packages.


Hi Ravi !

The main problem is that there are no enabled repositories, which can easily be solved ... the best for you would be to start over from scratch.

First clean up everything - open a terminal and execute the following commands :

sudo subscription-manager remove --all
sudo subscription-manager unregister
sudo subscription-manager clean

Now re-register the system, attach the subscriptions - execute these commands :

sudo subscription-manager register
sudo subscription-manager refresh
sudo subscription-manager attach --auto

Here are the commands to see which repos are enabled and what can be added :

Execute sudo subscription-manager repos --list-enabled to see all actually enabled subscriptions.
Execute sudo subscription-manager repos --list to see all subscriptions that are available for you.
Execute sudo subscription-manager repos --enable <repo> if you want to add additional repos.

Additional information : I have tested this solution on my RHEL Server 7.3 system which has the free Developer Edition subscription attached.

As you say that you're trying the RHEL 7.4 beta edition and I don't know if the main repos are enabled automatically - you may need to add them manually with the above mentioned command. Otherwise you alternatively can check out the current stable RHEL Server 7.3 edition.

I am not sure if installing and using RHEL 7.4 beta is generally covered by the free Developer edition, because there is no download option offered on the Developer Portal - so I suggest that you explore the stable version Red Hat Enterprise Linux Server 7.3 (Developer edition).

Cheers :)

When trying to access on RHEL 7.4 Beta is on there.

Yes, on RHEL 7.4 Beta is available, but not the beta version of the developer edition ! :)

What is a beta version of developer edition anyway?

As far as I know the subscription from the developer portal actually adds a Developer Suite(RH2262474) to the Red Hat account and gives you access to RHEL repositories.

Would it be a problem of how beta version of RHEL works anyway? I find that it is not really possible to select a particular minor version of RHEL when attempting to download a specific package on

The thing is that the download needs to be invoked from the website and not from the website to make use of the free (no-cost) version of the RHEL developer edition. :)

Invoking the download on will automatically add a Developer Suite(RH2262474) to the Red Hat account and can be seen on I can download RHEL 7.4 Beta on and attach the system normally to developer suite as shown on showing a system attached to developer subscription.

Thank you for clarification and pointing this out. What I basically wanted to say is that firstly you need that free subscription from the Developer Portal and secondly that you can't download the 7.4 beta from there because this option is only available from the Customer Portal. Maybe I didn't express it precise enough. :)

Thanks Christian, it is working for me ..

That's nice, you're welcome Anuj ! :)

Thank you

You're welcome ! :)

This is very helpful. Thanks.

You're welcome ! Glad it could help you, Olumide. :)

Thanks Christian, As you correctly guessed, my subscription level does not allow updating the system. Thanks Again.

You're welcome Ravi ! :)

Hi Ravi, today I installed RHEL 7.4 Beta to test if it works and can confirm the success Kwong Hei Tsang reported. So when you install the RHEL Server 7.4 Beta edition and attach the Developer Suite subscription, you can add the repositories just the way I described it. Of course I mean the "normal" Server edition and not the Red Hat Enterprise for Real Time version.

Can you see if there is a rhel-7-server-rt-rpms channel in subscription-manager?

I just looked at the documentation and it is installed by first installing the normal RHEL and then turn on real time channel and download the new kernel.

Make sure you can see your subscription on after you get the subscription from, you should see a developer suite in your redhat account

You need to do 1. subscription-manager auto-attach 2. subscription-manager attach --auto 3. yum update

and then it should work. I just tested it in RHEL 7.4.

You're right - but you and me, we are talking about RHEL Server and Ravi seems to be using RHEL for Real Time. That's why I suggested that he should consider to use the Red Hat Enterprise Linux Server edition in my reply (above) to his question. :)

I got rid of 7.4 beta, installed 7.3 Redhat Enterprice Linux (first available download under Downloads section of developer.redhat). Executed, subscription manager commands per Christian, but still no success. Here's my output. Please help.

subscription-manager register

Registering to: Username: (username) Password: The system has been registered with ID: (some id)

subscription-manager refresh

All local data refreshed

subscription-manager attach --auto

Installed Product Current Status: Product Name: Red Hat Enterprise Linux Server Status: Not Subscribed Unable to find available subscriptions for all your installed products.

Hi Ravi,

Please check whether your subscription is listed in the Customer Portal under Subscriptions and if the system is listed under Systems. In case there is nothing listed, sign in to the Developer Portal, invoke the download from there (you can cancel it at once) to generate the notification to accept the current T&Cs. Then retry to attach the subscription and to add repositories. In case the subscription and the system is listed in the Customer Portal and you already accepted the T&Cs, please contact the Customer Support. Also, you say that you chose the first download option - why didn't you choose the full RHEL DVD ?
Did you check your internet connection ? A working internet connection is necessary to perform everything of course ... :)

Christian/Kwong, access page shows I have a 'Red Hat Enterprise Linux Developer Suite' subscription active. Whole subscription manager seems a bit funny. I'll try a few combinations of options to see if it works,

As as last attempt I'll attempt to contact support. If it doesn't work, I'll just continue to use DVD as repository. But I am afraid I may not get updates or even new packages. I am generally from Debian background, but just wanted to check RH ecosystem. Thanks for all your help. Appreciate your time and effort. Ravi

You're welcome ! :) No, you won't get updates when the subscription is not properly attached, so better contact support.

You may also want to check if there are unused systems attached to any subscriptions.

Last I knew the Developer Suite allows 1 physical instance and 100 virtual guests. You won't be able to get updates on systems beyond the quota.

I think the support should be able to help you.

I just created another developer account, and used it for subscription purposes. It worked !!! For reasons that aren't clear to me. Just when I was about to give up on RHEL. Thanks folks.

Goto and delete all active subscriptions.

Thanks , Worked for me as well .

You're welcome, Navin ! :)

thanks a lot Christian on this method, it works on my system! :)

You're welcome, Siti ! :)


This appears to not work with the RHEL 8 Beta available with a free Developer subscription. Can you indicate how to proceed to get updates enabled? thanks

Hi Karsten,

Firstly, you need the dedicated RHEL 8 Beta subscription, not the developer subscription. Secondly, you won't get updates when running sudo dnf upgrade - because Red Hat didn't release any updates for the beta until now. :)


@Christian. It woks for me , thanks a million!!

Gladly, Daniel ... you're welcome ! :)

Perfect Solution.

Thank you, Debargho ! :)

Hi Team , I have registered to redhat as a developer and i am using RHEL linux 7.5 in my virtual machine.I regstered with redhat with username and password and gave auto attach.But still when i try to exectute teh yum install command i get the below error

The system has been registered with an entitlement server ,but it is not receiving updates.You can use subscription manager to assign subscriptions.CoULD any one please help me !!!!!!!!!!!!1

Hi Lakshmi,

Please try the --pool option instead of --auto - execute the following commands. : )

sudo subscription-manager remove --all
sudo subscription-manager unregister
sudo subscription-manager clean

sudo subscription-manager register
sudo subscription-manager refresh

sudo subscription-manager list --available (search for the matching Pool ID)
sudo subscription-manager attach --pool=<Pool-ID>


Hi Dear Redhat, Your repository CDN server is down at akamai.

Hi Christian, Thanks, perfect solution this worked for me.

You're welcome, John ! Glad it worked fine for you. :)


Hi Christian

I tried all of your guidance but still not able to update . I install this on this same pc but due to issues in windows on HDD I had to format my hard disk and had to re-install redhat on same machine . After that I have started seeing this error and not able to move forwward . Initially I never faced this problem during my first installation .

Can you please help ?

I have literally tried each and every command mentioned in above discussion forum.

Pool ID: 8a85f99a727637a90172ae6d115e134d Provides Management: No Available: 16 Suggested: 1 Service Type:
Service Level: Self-Support Usage:
Subscription Type: Standard Starts: 13/06/20 Ends: 13/06/21 Entitlement Type: Physical

[root@UNKNOWN ~]# [root@UNKNOWN ~]# sudo subscription-manager attach pool=8a85f99a727637a90172ae6d115e134d cannot parse argument: pool=8a85f99a727637a90172ae6d115e134d [root@UNKNOWN ~]# [root@UNKNOWN ~]# sudo subscription-manager attach --pool=8a85f99a727637a90172ae6d115e134d Successfully attached a subscription for: Red Hat Developer Subscription [root@UNKNOWN ~]# [root@UNKNOWN ~]# [root@UNKNOWN ~]# sudo yum update -y Updating Subscription Management repositories. Error: There are no enabled repositories in "/etc/yum.repos.d", "/etc/yum/repos.d", "/etc/distro.repos.d". [root@UNKNOWN ~]# [root@UNKNOWN ~]#

with best regards Pradeep Nehe

Hi Pradeep,

There seems to be a strange configuration ... who created the directories /etc/yum/repos.d and /etc/distro.repos.d ?
The repository files are located in the /etc/yum.repos.d directory. Please remove the two other ones and try it again.

Un-register the system :

sudo subscription-manager remove --all
sudo subscription-manager unregister
sudo subscription-manager clean

Re-register the system :

sudo subscription-manager register
sudo subscription-manager refresh

Search for the Pool ID :

sudo subscription-manager list --available

Attach the subscription :

sudo subscription-manager attach --pool=<Pool-ID>

Cleanup dnf and cache :

sudo yum clean all
sudo rm -r /var/cache/yum

Update the resources :

sudo yum update

In case you are doing it on a RHEL 8 system - replace yum with dnf in the commands ... I wish you good luck ! :)