Addition to Install docs for Satellite behind a proxy

Latest response

I ran into the issue where we're behind a proxy and have selinux locking things down. We recieved the access denied error when we were expanding the Repository products:

Permission denied – connect(2) for “” port

To fix, I used the line from https://access.redhat.com/solutions/1308183 :

semanage port -a -t foreman_proxy_port_t -p tcp <http_proxy_port>

Since the semanage of ports was mentioned earlier in the document, this may be a big help to anybody else behind it who runs into the error to save them from having to hunt it down.

John Peters's picture

Responses

Hello, can you confirm which version of Satellite you are using?

Reading the Red Hat Bugzilla[1] attached to that solution, it appears this issue was solved in 6.1.0 by getting the installer to configure the settings. If I have misunderstood, or if anything is unclear, then we can raise a bug to get the guides improved.

Thank you

[1] Bug 1177377 - Satellite 6.1 does not work with http proxy due to SELinux denials

Version 6.2.8.

Just realized the error didn't render correctly in the original post. It should be (x's = IP, y's = port #):

Permission denied – connect(2) for “x.x.x.x” port yyyy

OK, Version 6.2.8., thank you, and are you using --katello-proxy-port= in your installation script? Reason for asking, I thought that option would also set the SELinux permissions. If you used that option and had the problem then I will ask the developers and open a new bug.

Thank you

The relevant section in the 6.2 Installation Guide is Configuring Satellite Server with HTTP Proxy.

Correct. Used --katello-proxy-port= immediately after --katello-proxy-url=.

Ok, thanks for the confirmation. I have opened this Red Hat Bugzilla Bug 1444361 - Satellite 6.2 does not work with http proxy due to SELinux denials.

Feel free to add yourself to the c.c. field if you want to follow it.

Was this helpful?

We appreciate your feedback. Leave a comment if you would like to provide more detail.
It looks like we have some work to do. Leave a comment to let us know how we could improve.
Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.