Swift list failed with json 400 bad request invalid path

Posted on

I am getting the below error when I try to run the command:
swift list

I followed the installation procedures outlined in this URL:
https://access.redhat.com/documentation/en/red-hat-openstack-platform/9/paged/installation-reference/

No errors were seen when I installed the keystone service and validation of the kesystone was also successful.
I then installed the object service packages and configured the account, container and object services with ports 6202, 6201 and 6200 respectively.
I then mounted an XFS disk to the location /srv/node/d1. I used this as the mount point when I was configuring the account, container and object services. Then started the three services All services started running. However, when I check the status, this error was seen.

"liberasurecode_backend_open: dynamic linking error libJerasure.so.2: cannot open shared object file: No such file or directory"

Despite this error, the status of the services is "Running". However all three services namely openstack-swift-object, openstack-swift-account and openstack-swift-container show this error.

Now, when I run the command swift list, I get the below error.

Account GET failed: http://xxx.xxx.xxx.xxx:8080/v1/AUTH_xxxxxxxxxxxxxxxxxxxxxxxxxxxx?format=json 400 Bad Request [first 60 chars of response] Invalid path: /srv/node/d1/1/xxxxxxxxxxxxxxxxxxxxxxxxxxxx

I had actually mounted two XFS disks, one each in /srv/node/d1 and /srv/node/d2. I needed only one so I continued with /srv/node/d1.
Please help with this error.

Thanks,
Badri