Bash Vulnerablilty RHEL 5.3 bash-3.2-24.el5

Latest response

We have one machine running Red Hat Enterprise Linux Server release 5.3 (Tikanga).
The current version on bash is:
[root@lcp102 ~]# rpm -q bash
bash-3.2-24.el5

I tried to update bash and got the following:
[root@lcp102 ~]# yum update bash
Loaded plugins: rhnplugin
Setting up Update Process
No Packages marked for Update

Should this "yum update bash" work on our 5.3 Red Hat? It worked on 5.8, 5.9, and 6.5.

I am a dba (not an sa) for small company, so help would be appreciated.

Thanks,
Steve

Responses

Steve,

It should/will, but it depends on the repository your yum configuration is pointing to. You may be pointing to a local directory / ISO, or a static repository that doesn't receive the updates.

Do you run Satellite internally in your organisation? or are your servers registered to rhn individually?

Start by running 'yum clean all' and re-attempt the bash update.
Failing that, 'yum repolist' will give you an idea of the repositories that your host is configured to use.

Thanks,
I did more research on the yum clean all and yum clean metadata...

I did:
yum clear metadata
yum update bash

This now found the patch and upgraded it.

Thanks