How does one set "-i" for postmaster on RHEL7 PostgreSQL?

Latest response

Hopefully I am not missing something obvious, but I can't seem to resolve how to provide the necessary "-i" to postmaster to get it to listen for non-local network connections.

/usr/lib/systemd/system/postgresql.service has

ExecStart=/usr/bin/pg_ctl start -D ${PGDATA} -s -o "-p ${PGPORT}" -w -t 30

back in the good ole days of RHEL6, getting PGOPTS="-i" in proper /etc/sysconfig file would do the trick.

Thanks!

Responses

Of course, perhaps I have answered my own question :( "man postgres"

       -i
           Allows remote clients to connect via TCP/IP (Internet domain)
           connections. Without this option, only local connections are
           accepted. This option is equivalent to setting listen_addresses to
           * in postgresql.conf or via -h.

           This option is deprecated since it does not allow access to the
           full functionality of listen_addresses. It's usually better to set
           listen_addresses directly.