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OSD/ROSA クラスターを手動でシャットダウンする方法

Solution Verified - Updated -

Environment

  • Red Hat OpenShift Service on AWS (ROSA)
    • 4
  • Red Hat OpenShift Dedicated (OSD)
    • 4

Issue

  • 稼働コストを節約するために、 OSD/ROSA クラスターをシャットダウンすることは可能ですか?
  • 稼働コストを節約するために、直接 AWS 操作を介して ROSA クラスターをシャットダウンする必要があります。
  • ROSA クラスターをシャットダウンした後、次のアラートが表示されます。

    Your cluster requires you to take action because it is no longer registering with Red Hat OpenShift Cluster Manager. Possible causes include stopping instances or a networking misconfiguration. If you intended to terminate this cluster then please delete the cluster. Otherwise file a support request.
    

Resolution

Red Hat はこの問題を認識しており、この機能を追加するための内部タスクが作成されました (SDE-685)。

クラスターがしばらく必要ない場合は、永続データをバックアップし、CI/CD ソリューションが配置されていることを確認した後に、クラスターを削除することができます。必要に応じて、新しいクラスターを再度作成できます。

OSD または ROSA クラスターが手動でシャットダウンされると、次のアラートがトリガーされます。

Your cluster requires you to take action because it is no longer registering with Red Hat OpenShift Cluster Manager. Possible causes include stopping instances or a networking misconfiguration. If you intended to terminate this cluster then please delete the cluster. Otherwise file a support request.

Root Cause

本ドキュメントに示されているように、OSD または ROSA クラスターのシャットダウンはまだサポートされていません。

Shutting down the underlying infrastructure through the cloud provider console is unsupported and can lead to data loss.

ROSA と OSD はマネージドサービスであるため、コントロールプレーンとインフラストラクチャーを含むクラスターは SRE チームによって管理され、SRE の制御下で常に利用できる必要があります。
クラスターのシャットダウンが長期間にわたると、SRE 管理ツール/クラスター/コンポーネントが古くなります。Openshift クラスターは、長期間シャットダウンされることは想定されていません。

ROSA および OSD CCS はお客様の AWS アカウントに基づいているため、お客様はすべての AWS リソースを制限なく制御できます。しかし、ROSA 上で自由に扱えるわけではありません。ROSA のドキュメント に記載されている場合を除き、AWS の直接操作することは想定されていません。

Diagnostic Steps

ROSA クラスターをシャットダウンした後、次のアラートが表示されます。

Your cluster requires you to take action because it is no longer registering with Red Hat OpenShift Cluster Manager. Possible causes include stopping instances or a networking misconfiguration. If you intended to terminate this cluster then please delete the cluster. Otherwise file a support request.

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

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