Node stuck on power state "None" in Red Hat OpenStack Platform

Solution Verified - Updated -

Issue

openstack baremetal node list returns node with power state set to None

stack@undercloud $ openstack baremetal node list                        
+--------------------------------------------+-------------+-------------------------------------------+-------------+----------+-------------+  
| UUID                                                                             | Name             | Instance UUID                                                          | Power State | Prov State | Maintenance |
+--------------------------------------------+-------------+--------------------------------------------+------------+-----------+-------------+
| a2443d94-f552-44b9-9d3c-9aa77748d6d0 | controller-0 | 50bb5f9f-2fa2-4cc4-8498-69acd4fe5e22    | None           | active             | False       |
| 2397dc53-8e94-448e-8cc2-54893ede51d3  | controller-1  | 48455b03-964b-493c-a154-578450c786f6 | power on    | active             | False       |
| 5096cd4c-aded-4722-b5a7-b403d50a8e54 | controller-2 | 4734aa3d-8ace-4947-bd37-e046b5189a11    | power on    | active             | False       |
| da3fde2e-04db-48c4-8670-57c12087cae7    | compute-0 | dc5128e2-a2fb-43fa-bbc4-89c58aaf6624     | power on     | active             | True        |

Environment

  • Red Hat Openstack Platform 10 (RHOSP10)
  • Red Hat Openstack Platform 13 (RHOSP13)

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In