ClientException with HTTP 500 after executing OpenStack related Commnds

Solution Verified - Updated -

Issue

If you run some openstack commands on one of clustered controller nodes configured, its result ends up with HTTP 500 periodically. One of possibilities causing this issue is bad time synchronization.

~# nova list
+--------------------------------------+----------------------------------+--------+ ... +
| ID                                   | Name                             | Status | ... |
+--------------------------------------+----------------------------------+--------+ ... +
 ...
| yyyyyyy-yyyy-yyyy-yyyy-yyyyyyyyyyyy  | abc.local.host                   | ACTIVE | ... |
 ...
+--------------------------------------+----------------------------------+--------+ ... +
~# nova list
+--------------------------------------+----------------------------------+--------+ ... +
| ID                                   | Name                             | Status | ... |
+--------------------------------------+----------------------------------+--------+ ... +
 ...
| yyyyyyy-yyyy-yyyy-yyyy-yyyyyyyyyyyy  | abc.local.host                   | ACTIVE | ... |
 ...
+--------------------------------------+----------------------------------+--------+ ... +

~# nova list
ERROR (ClientException): The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-xxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx)

Environment

Red Hat Enterprise Linux OpenStack Platform 7

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In