Red Hat Training

A Red Hat training course is available for Red Hat Enterprise Linux

3.5. Notes on UEFI Support

3.5.1. Feature Support

Red Hat Enterprise Linux 6.9 supports both BIOS and UEFI firmware on AMD64 and Intel 64 systems (x86_64). UEFI-based systems are supported with the following limitations:
  • The system must support UEFI Specification 2.0 or later. Earlier revisions are not supported.
  • The Secure Boot technology is not supported, and will prevent Red Hat Enterprise Linux from being installed. Systems using UEFI Specification 2.2 or later must have Secure Boot disabled in order to install and run Red Hat Enterprise Linux 6.9.
Systems using UEFI 2.0 later with Secure Boot disabled (if present) can install and boot Red Hat Enterprise Linux without issues, although not all features in the relevant UEFI specification are supported.
For more information about UEFI specifications, see http://www.uefi.org/specifications.