Translated message

A translation of this page exists in English.

在HP xw9300工作站上安装红帽企业Linux 4需要哪些内核命令行参数?

已更新 -

HP xw9300工作站上需要在/etc/grub.conf文件的核心命令行里加上acpi=off,这样可以在单核心或者双核心配置上正确支持红帽企业linux 4 Update 1。

对红帽企业Linux 4 Update 2,不需要任何核心命令行参数。

如果你在任何其他双核系统上碰到过问题,典型的是在启动时候核心panic,那么你可能需要尝试在/etc/grub.conf里加入下面的一个或者全部核心命令行参数:

  • 红帽企业Linux 4 Gold版:

     - 不支持双核系统
    
  • 红帽企业Linux 4 Update 1:

     - numa=off
     - acpi=off
    
  • 红帽企业Linux 4 Update 2和以上

     - pci=noseg
     - pci=nommconf
    

注:以上并不适用于红帽企业Linux 3,然后,为了支持xw9300双核,需要Update 5。

如果你想在grub.conf文件里加入上面的选项,可以使用下面的例子:

title Red Hat Enterprise Linux AS (2.6.9-11.EL)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-11.EL ro root=LABEL=/ acpi=off console=ttys0
        initrd /initrd-2.6.9-11.EL.img

多个核心命令行参数应该被空格隔开。要让改变生效,你需要重启系统。