camel-ssh version requirement

Solution In Progress - Updated -

Issue

We are using 2.10.0.redhat-60024 version of camel jars as officially certified version from Redhat.

There is a new functionality we are adding to our project that uses ssh support from camel via camel-ssh jar. However we noticed that the current came-ssh jar version does not fulfil our requirements and we need to use a later version that has this support.

To be specific - for our new functionality, we are referring to sshd-core jar which is a dependency of the camel-ssh jar. The current certified redhat version we are using - 2.10.0.redhat-60024 - comes with camel-ssh jar that uses version 0.6.0 of sshd-core jar. And we need to use 0.9.0 version for our new functionality.

As possible solutions, we are looking at:
1. a later version certified by Redhat that uses version 0.9.0 of sshd-core.jar
2. add version 0.9.0 of sshd-core.jar to our current set up and have Redhat certify the same for usage and support.
3. any other alternative solution you think that can be suitable for this scenario.

Environment

Red Hat JBoss Fuse 6.1.0

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content