Why do I get stuck on a 'Please Wait, Loading...' dialogue box shown on top of the report when accessing RHEV Reports?
Environment
- Red Hat Enterprise Virtualization 3.3.
- Internet Explorer running in "Compatibility View" mode.
Issue
- When accessing a RHEV report I'm stuck on a "Please Wait, Loading..." dialogue box shown on top of the report:

Resolution
-
To resolve the issue, follow the below steps to set Internet Explorer not to use Compatibility View mode:
- Open "Tools" menu and select "Compatibility View settings" option.
- Ensure that no full or partial match for the URL of RHEV webadmin and reports portal is listed in "Websites you've added to Compatibility View".
- If Internet Explorer considers RHEV webadmin and reports portal to be an "Intranet site", please uncheck "Display intranet sites in Compatibility View".
-
This issue was being tracked in Red Hat Bugzilla #889547, this is a private bugzilla.
Root Cause
-
Internet Explorer considers RHEV webadmin and reports portal to be an "Intranet site".
-
Internet Explorer uses "Compatibility View" by default for all "Intranet sites".
-
RHEV Reports portal requires "Compatibility View" mode of Internet Explorer not to be used to function properly.
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