Error while loading shared libraries: libXtst.so.6: wrong ELF class: ELFCLASS32

Solution Unverified - Updated -

Issue

  • Following error persists while trying to run xdpyinfo command, which requires the libXtst.so.6 library module:

    $ xdpyinfo
    xdpyinfo: error while loading shared libraries: libXtst.so.6: wrong ELF class: ELFCLASS32
    

Environment

  • Red Hat Enterprise Linux 5

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In