User not able to login when using OpenID with On-Prem AD FS
Environment
- Red Hat OpenShift Service on AWS (ROSA) 4.x
Issue
- The claims in the
oauth
do not match the ones configured in theOIDC AD FS
.
Resolution
- The
claims
configured inOIDC
and in theoauth
config need to match.
Root Cause
- The claims in the oauth do not match the ones configured in the
OIDC AD FS
.
Diagnostic Steps
- When an user tries to login the following error is observed in the authentication pods:
2023-08-23T11:06:10.165336729Z E0823 11:06:10.165119 1
errorpage.go:28] AuthenticationError: Requested parameter not
sent2023-08-23T11:06:17.836839630Z E0823 11:06:17.836785 1
errorpage.go:28] AuthenticationError: Requested parameter not sent
- Verify the claims in the aouth cluster:
$ oc get oauth cluster -o yaml
*
*
*
mappingMethod: claim
name: OpenID-ADFS
openID:
ca:
name: caXXXXXXXXXXXXX
claims:
email:
- email
name:
- name
preferredUsername:
- dev
*
*
*
- Verify the claims configured/supported in the AD FS side:
https://<FQDN>/adfs/.well-known/openid-configuration
*
*
*
"claims_supported": ["aud",
"iss",
"iat",
"exp",
"auth_time",
"nonce",
"at_hash",
"c_hash",
"sub",
"upn",
"unique_name",
"pwd_url",
"pwd_exp",
"mfa_auth_time",
"sid"
*
*
*
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