Why does `rpm -Va --nofiles` give output like "Unsatisfied dependencies for xyz package" ?

Solution Unverified - Updated -

Issue

  • While running rpm -Va --nofiles command on terminal, the following output is given.
Unsatisfied dependencies for compat-libstdc++-296-2.96-138.i386: libgcc_s.so.1, libgcc_s.so.1(GLIBC_2.0)
Unsatisfied dependencies for libgsf-1.14.1-6.1.x86_64: libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for libgnomeui-2.16.0-5.el5.x86_64: gnome-vfs2 >= 2.5.3, libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for libbonoboui-2.16.0-1.fc6.i386: libgdk-x11-2.0.so.0, libgdk_pixbuf-2.0.so.0, libgnomevfs-2.so.0, libgtk-x11-2.0.so.0, libpopt.so.0, libxml2.so.2, libz.so.1
Unsatisfied dependencies for gnome-python2-2.16.0-1.fc6.x86_64: libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for fipscheck-lib-1.2.0-1.el5.x86_64: fipscheck < 1.2.0-1
Unsatisfied dependencies for evolution-data-server-1.12.3-18.el5.i386: libcom_err.so.2, libgdk-x11-2.0.so.0, libgdk_pixbuf-2.0.so.0, libgnomevfs-2.so.0, libgnutls.so.13, libgtk-x11-2.0.so.0, libnspr4.so, libnss3.so, libnss3.so(NSS_3.2), libnss3.so(NSS_3.3), libnss3.so(NSS_3.4), libnssutil3.so, libplc4.so, libplds4.so, libpopt.so.0, libsasl2.so.2, libsmime3.so, libsmime3.so(NSS_3.2), libsmime3.so(NSS_3.4), libsmime3.so(NSS_3.4.1), libsmime3.so(NSS_3.6), libssl3.so, libssl3.so(NSS_3.2), libxml2.so.2, libz.so.1
Unsatisfied dependencies for gail-1.9.2-3.el5.i386: libgdk-x11-2.0.so.0, libgdk_pixbuf-2.0.so.0, libgtk-x11-2.0.so.0
Unsatisfied dependencies for libusb-0.1.12-6.el5.i386: libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libstdc++.so.6, libstdc++.so.6(CXXABI_1.3), libstdc++.so.6(GLIBCXX_3.4)
Unsatisfied dependencies for openssl-0.9.8e-22.el5_8.4.i686: libcom_err.so.2, libz.so.1
Unsatisfied dependencies for cpqacuxe-8.70-9.0.i386: libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libgcc_s.so.1(GLIBC_2.0), libstdc++.so.6, libstdc++.so.6(CXXABI_1.3), libstdc++.so.6(GLIBCXX_3.4)
Unsatisfied dependencies for compat-db-4.2.52-5.1.i386: libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libgcc_s.so.1(GLIBC_2.0), libstdc++.so.6, libstdc++.so.6(CXXABI_1.3), libstdc++.so.6(GLIBCXX_3.4)
Unsatisfied dependencies for fontconfig-2.4.1-7.el5.i386: libfreetype.so.6
Unsatisfied dependencies for libXft-2.1.10-1.1.i386: libfreetype.so.6
Unsatisfied dependencies for libglade2-2.6.0-2.i386: libgdk-x11-2.0.so.0, libgdk_pixbuf-2.0.so.0, libgtk-x11-2.0.so.0, libxml2.so.2, libz.so.1
Unsatisfied dependencies for pam_ccreds-3-5.i386: libpam.so.0, libpam.so.0(LIBPAM_1.0), libpam_misc.so.0
Unsatisfied dependencies for system-config-soundcard-2.0.6-1.el5.noarch: kudzu
Unsatisfied dependencies for firstboot-1.4.27.3-1.el5.noarch: libuser
Unsatisfied dependencies for gstreamer-0.10.20-3.el5.i386: libxml2.so.2, libz.so.1
Unsatisfied dependencies for usermode-1.88-3.el5.2.x86_64: libuser.so.1()(64bit)
Unsatisfied dependencies for gstreamer-plugins-base-0.10.20-3.0.1.el5_3.x86_64: libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for fipscheck-lib-1.2.0-1.el5.x86_64: fipscheck < 1.2.0-1
Unsatisfied dependencies for libpng-1.2.10-17.el5_8.i386: libz.so.1
Unsatisfied dependencies for ecryptfs-utils-75-8.el5.i386: libnss3.so, libnss3.so(NSS_3.2), libnss3.so(NSS_3.3), libnssutil3.so, libpam_misc.so.0, libsmime3.so, libssl3.so, libz.so.1
Unsatisfied dependencies for rhpxl-0.41.1-12.el5.x86_64: kudzu >= 1.2.0
Unsatisfied dependencies for nautilus-extensions-2.16.2-10.el5.x86_64: libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for yelp-2.16.0-29.el5.x86_64: gecko-libs >= 10.0, gnome-vfs2 >= 2.0.0, libgnomevfs-2.so.0()(64bit), libmozalloc.so()(64bit), libxpcom.so()(64bit), libxul.so()(64bit)
Unsatisfied dependencies for openldap-2.3.43-25.el5_8.1.i386: libsasl2.so.2
Unsatisfied dependencies for hpvca-6.2.1-1.i386: libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libgcc_s.so.1(GLIBC_2.0)
Unsatisfied dependencies for svrcore-4.0.4-3.el5.i386: libnspr4.so, libnss3.so, libnss3.so(NSS_3.10.2), libnss3.so(NSS_3.2), libplc4.so, libplds4.so, libssl3.so
Unsatisfied dependencies for libxklavier-3.0-3.el5.i386: libxml2.so.2, libz.so.1
Unsatisfied dependencies for cairo-1.2.4-5.el5.i386: libfreetype.so.6, libz.so.1
Unsatisfied dependencies for libgnomecanvas-2.14.0-4.1.i386: libgdk-x11-2.0.so.0, libgdk_pixbuf-2.0.so.0, libgtk-x11-2.0.so.0, libxml2.so.2, libz.so.1
Unsatisfied dependencies for gnome-desktop-2.16.0-1.fc6.x86_64: libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for gnome-desktop-2.16.0-1.fc6.i386: libgdk-x11-2.0.so.0, libgdk_pixbuf-2.0.so.0, libgnomevfs-2.so.0, libgtk-x11-2.0.so.0, libpopt.so.0, libxml2.so.2, libz.so.1
Unsatisfied dependencies for eel2-2.16.1-1.el5.i386: gnome-vfs2 >= 2.7.91, libgdk-x11-2.0.so.0, libgdk_pixbuf-2.0.so.0, libgnomevfs-2.so.0, libgtk-x11-2.0.so.0, libpopt.so.0, libxml2.so.2, libz.so.1
Unsatisfied dependencies for gnome-python2-bonobo-2.16.0-1.fc6.x86_64: libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for control-center-2.16.0-16.el5.i386: libfreetype.so.6, libgdk-x11-2.0.so.0, libgdk_pixbuf-2.0.so.0, libgnomevfs-2.so.0, libgtk-x11-2.0.so.0, libhal.so.1, libpopt.so.0, libxml2.so.2, libz.so.1
Unsatisfied dependencies for fipscheck-lib-1.2.0-1.el5.x86_64: fipscheck < 1.2.0-1
Unsatisfied dependencies for libbonobo-2.16.0-1.1.el5_5.1.i386: libxml2.so.2, libz.so.1
Unsatisfied dependencies for hp-snmp-agents-8.7.0.23-17.x86_64: libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libstdc++.so.6, libstdc++.so.6(CXXABI_1.3), libstdc++.so.6(GLIBCXX_3.4), net-snmp
Unsatisfied dependencies for hpaducli-8.60-8.0.i386: libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libgcc_s.so.1(GLIBC_2.0), libstdc++.so.6, libstdc++.so.6(CXXABI_1.3), libstdc++.so.6(GLIBCXX_3.4)
Unsatisfied dependencies for trousers-0.3.1-4.el5.i386: libgdk-x11-2.0.so.0, libgdk_pixbuf-2.0.so.0, libgtk-x11-2.0.so.0
Unsatisfied dependencies for passwd-0.73-2.x86_64: libuser.so.1()(64bit)
Unsatisfied dependencies for metacity-2.16.0-16.el5.i386: libgdk-x11-2.0.so.0, libgdk_pixbuf-2.0.so.0, libgtk-x11-2.0.so.0
Unsatisfied dependencies for redhat-lsb-4.0-2.1.4.el5.i386: /usr/bin/man, libgcc_s.so.1, libnspr4.so, libnss3.so, libpam.so.0, libssl3.so, libstdc++.so.6, libz.so.1
Unsatisfied dependencies for cups-libs-1.3.7-30.el5.i386: libcom_err.so.2, libgnutls.so.13, libgnutls.so.13(GNUTLS_1_3), libtiff.so.3, libz.so.1
Unsatisfied dependencies for pam_krb5-2.2.14-22.el5.i386: libcom_err.so.2, libpam.so.0, libpam.so.0(LIBPAM_1.0)
Unsatisfied dependencies for system-config-users-1.2.51-7.el5.noarch: libuser >= 0.53.1
Unsatisfied dependencies for nautilus-extensions-2.16.2-10.el5.i386: libgdk-x11-2.0.so.0, libgdk_pixbuf-2.0.so.0, libgnomevfs-2.so.0, libgtk-x11-2.0.so.0
Unsatisfied dependencies for nfs-utils-lib-1.0.8-7.9.el5.x86_64: nfs-utils >= 1.0.9-45
Unsatisfied dependencies for beecrypt-4.1.2-10.1.1.i386: libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libstdc++.so.6, libstdc++.so.6(CXXABI_1.3), libstdc++.so.6(GLIBCXX_3.4)
Unsatisfied dependencies for gnome-keyring-0.6.0-1.fc6.i386: libgdk-x11-2.0.so.0, libgdk_pixbuf-2.0.so.0, libgtk-x11-2.0.so.0
Unsatisfied dependencies for librsvg2-2.16.1-1.el5.x86_64: gnome-vfs2 >= 1.9.16, libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for libbonoboui-2.16.0-1.fc6.x86_64: libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for eel2-2.16.1-1.el5.x86_64: gnome-vfs2 >= 2.7.91, libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for libgnomeui-2.16.0-5.el5.i386: gnome-vfs2 >= 2.5.3, libgdk-x11-2.0.so.0, libgdk_pixbuf-2.0.so.0, libgnomevfs-2.so.0, libgtk-x11-2.0.so.0, libpopt.so.0, libxml2.so.2, libz.so.1
Unsatisfied dependencies for libgail-gnome-1.1.3-1.2.1.x86_64: libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for control-center-2.16.0-16.el5.x86_64: libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for TIVsm-API-5.5.1-0.i586: libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libgcc_s.so.1(GLIBC_2.0)
Unsatisfied dependencies for libsoup-2.2.98-2.el5_3.1.i386: libgnutls.so.13, libgnutls.so.13(GNUTLS_1_3), libxml2.so.2, libz.so.1
Unsatisfied dependencies for evolution-data-server-1.12.3-18.el5.x86_64: libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for ILMT-TAD4D-agent-7.2.2-1.i386: libgcc_s.so.1
Unsatisfied dependencies for hpacucli-8.70-8.0.i386: libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libgcc_s.so.1(GLIBC_2.0), libstdc++.so.6, libstdc++.so.6(CXXABI_1.3), libstdc++.so.6(GLIBCXX_3.4)
Unsatisfied dependencies for mesa-libGLU-6.5.1-7.10.el5.i386: libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libstdc++.so.6, libstdc++.so.6(CXXABI_1.3), libstdc++.so.6(GLIBCXX_3.4)
Unsatisfied dependencies for curl-7.15.5-15.el5.i386: libcom_err.so.2, libz.so.1
Unsatisfied dependencies for pam_pkcs11-0.5.3-26.el5.i386: libnspr4.so, libnss3.so, libnss3.so(NSS_3.10), libnss3.so(NSS_3.2), libnss3.so(NSS_3.3), libnss3.so(NSS_3.4), libnss3.so(NSS_3.6), libnss3.so(NSS_3.7), libnss3.so(NSS_3.8), libnss3.so(NSS_3.9.2), libnss3.so(NSS_3.9.3), libnssutil3.so, libpam.so.0, libpam.so.0(LIBPAM_1.0), libpam.so.0(LIBPAM_EXTENSION_1.0), libplc4.so, libplds4.so, libsmime3.so, libssl3.so
Unsatisfied dependencies for system-config-network-tui-1.3.99.21-1.el5.noarch: kudzu
Unsatisfied dependencies for GConf2-2.14.0-9.el5.i386: libgdk-x11-2.0.so.0, libgdk_pixbuf-2.0.so.0, libgtk-x11-2.0.so.0, libpopt.so.0, libxml2.so.2, libz.so.1
Unsatisfied dependencies for gnome-mount-0.5-3.el5.x86_64: libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for gnome-panel-2.16.1-7.el5.x86_64: libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for compat-libstdc++-33-3.2.3-63.i386: libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libgcc_s.so.1(GCC_3.3), libgcc_s.so.1(GLIBC_2.0)
Unsatisfied dependencies for db4-4.3.29-10.el5_5.2.i386: libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libstdc++.so.6, libstdc++.so.6(CXXABI_1.3), libstdc++.so.6(GLIBCXX_3.4)
Unsatisfied dependencies for redhat-lsb-4.0-2.1.4.el5.x86_64: /usr/bin/man
Unsatisfied dependencies for cryptsetup-luks-1.0.3-8.el5.i386: libuuid.so.1
Unsatisfied dependencies for system-config-display-1.0.48-4.el5.noarch: kudzu >= 1.2.0
Unsatisfied dependencies for libgnome-2.16.0-6.el5.x86_64: gnome-vfs2 >= 2.5.3, libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for libgnome-2.16.0-6.el5.i386: gnome-vfs2 >= 2.5.3, libgnomevfs-2.so.0, libpopt.so.0
Unsatisfied dependencies for gnome-python2-gnomevfs-2.16.0-1.fc6.x86_64: gnome-vfs2 >= 2.0.2, libgnomevfs-2.so.0()(64bit)
Unsatisfied dependencies for coolkey-1.1.0-15.el5.i386: libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libnspr4.so, libnss3.so, libnssutil3.so, libplc4.so, libplds4.so, libsmime3.so, libsoftokn3.so, libsoftokn3.so(NSS_3.4), libssl3.so, libstdc++.so.6, libstdc++.so.6(CXXABI_1.3), libstdc++.so.6(GLIBCXX_3.4), libz.so.1
Unsatisfied dependencies for krb5-libs-1.6.1-70.el5.i386: libcom_err.so.2
Unsatisfied dependencies for pango-1.14.9-8.el5_7.3.i386: libfreetype.so.6
Unsatisfied dependencies for WFBwfftps-lftp-4.3.7-200.lnx.i386: libgcc_s.so.1, libgcc_s.so.1(GCC_3.0), libgcc_s.so.1(GCC_3.3), libgcc_s.so.1(GCC_4.2.0), perl(DBI)
Unsatisfied dependencies for HPOvPerfMI-11.03.011-1.x86_64: libgcc_s.so.1
  • Is there something wrong with above output?

Environment

  • Red Hat Enterprise Linux 6

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content