Errata #16584 causes update of OpenShift Enterprise to fail.

Solution Unverified - Updated -

Issue

  • Install of OpenShift Enterprise Failed, due to missing dependencies.
  • After applying Errata 16584 the following error is seen after updating.
--> Running transaction check
---> Package nodejs010-nodejs-commander.noarch 0:1.1.1-3.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.6.0 for package: nodejs010-nodejs-commander-1.1.1-3.el6op.noarch
---> Package nodejs010-nodejs-keypress.noarch 0:0.2.1-1.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) for package: nodejs010-nodejs-keypress-0.2.1-1.el6op.noarch
---> Package nodejs010-nodejs-optimist.noarch 0:0.4.0-2.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) for package: nodejs010-nodejs-optimist-0.4.0-2.el6op.noarch
---> Package nodejs010-nodejs-options.noarch 0:0.0.5-2.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.4.0 for package: nodejs010-nodejs-options-0.0.5-2.el6op.noarch
---> Package nodejs010-nodejs-supervisor.noarch 0:0.5.2-3.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.3.7 for package: nodejs010-nodejs-supervisor-0.5.2-3.el6op.noarch
---> Package nodejs010-nodejs-tinycolor.noarch 0:0.0.1-5.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.4.0 for package: nodejs010-nodejs-tinycolor-0.0.1-5.el6op.noarch
---> Package nodejs010-nodejs-wordwrap.noarch 0:0.0.2-2.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.4.0 for package: nodejs010-nodejs-wordwrap-0.0.2-2.el6op.noarch
---> Package nodejs010-nodejs-ws.x86_64 0:0.4.25-6.el6op will be installed
--> Processing Dependency: nodejs010-nodejs(engine) >= 0.4.0 for package: nodejs010-nodejs-ws-0.4.25-6.el6op.x86_64
---> Package openshift-origin-node-proxy.noarch 0:0.9.5-1.el6op will be an update
--> Processing Dependency: nodejs010-nodejs-async for package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch
--> Processing Dependency: nodejs010-nodejs for package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch
--> Finished Dependency Resolution
Error: Package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs
Error: Package: nodejs010-nodejs-options-0.0.5-2.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs(engine) >= 0.4.0
Error: Package: nodejs010-nodejs-optimist-0.4.0-2.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs(engine)
Error: Package: nodejs010-nodejs-tinycolor-0.0.1-5.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs(engine) >= 0.4.0
Error: Package: nodejs010-nodejs-ws-0.4.25-6.el6op.x86_64 (openshift_node)
           Requires: nodejs010-nodejs(engine) >= 0.4.0
Error: Package: openshift-origin-node-proxy-0.9.5-1.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs-async
Error: Package: nodejs010-nodejs-supervisor-0.5.2-3.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs(engine) >= 0.3.7
Error: Package: nodejs010-nodejs-wordwrap-0.0.2-2.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs(engine) >= 0.4.0
Error: Package: nodejs010-nodejs-commander-1.1.1-3.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs(engine) >= 0.6.0
Error: Package: nodejs010-nodejs-keypress-0.2.1-1.el6op.noarch (openshift_node)
           Requires: nodejs010-nodejs(engine)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Environment

  • Red Hat OpenShift Enterprise 1.2.7

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content