InstallPlan is not generated automatically after deleting existing InstallPlan

Solution Verified - Updated -

Environment

  • Red Hat OpenShift Container Platform
    • 4.x
  • Red Hat OpenShift Service on AWS
    • 4.x

Issue

  • While managing updates of operators based on Manual approval mode, InstallPlans were not generated automatically after cleaning existing ones.
  • There is the following error messages at catalog-operator pod logs in openshift-operator-lifecycle-manager.
Emmdd hh:mm:ss.ssssss       1 queueinformer_operator.go:290] sync "openshift-operators" failed: installplans.operators.coreos.com "install-XXXXX" not found

Resolution

Please check if there is an "olm.generated-by: install-XXXXX" annotation in all the Subscriptions of the same namespace which deployed your operators, and remove only the annotation if the annotation is linked with the missing InstallPlan. You can remove the annotation via CLI using:

$ oc annotate subscription <name-of-subscription> olm.generated-by-

As soon as you remove the above annotation, the InstallPlan would be generated automatically again. If not, delete the OLM operator pods in openshift-operator-lifecycle-manager to refresh the cache and generate a new InstallPlan:

$ oc delete pods -l 'app in (catalog-operator, olm-operator)' -n openshift-operator-lifecycle-manager

Root Cause

  • There is some operators depending on existing InstallPlan using "olm.generated-by" annotation like devworkspace-operator which is generated by devspaces subscription.

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

Comments