conflicting files in nvidia-tdk package (not shipped by Red Hat)

Solution Unverified - Updated -

Issue

  • Customer is maintaining custom local packages.
  • They are having issues with a package refusing to update due to what rpm says are conflicting files.
  • They see complaints such as:
file /usr/share/man/man3/nvmlUtilization_t.3.gz from install of nvidia-tdk-5.319.43-0.x86_64 conflicts with file from package nvidia-tdk-3.304.5-0.ch5.1.x86_64
  • In the above they are trying to update from nvidia-tdk-3.304.5-0.ch5.1.x86_64 to nvidia-tdk-5.319.43-0.x86_64.rpm
  • They are seeing this with both yum and rpm on 6.4 and 6.5

Environment

  • Red Hat Enterprise Linux 6
  • Custom local package.

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content