yum fails with "<package_name-version1> is a duplicate with <package_name-version2>"

Solution Verified - Updated -

Issue

  • The yum fails with below messages:
audit-libs-2.3.7-5.el6.x86_64 is a duplicate with audit-libs-2.2-2.el6.x86_64
bash-4.1.2-29.el6.x86_64 is a duplicate with bash-4.1.2-15.el6_4.x86_64
binutils-2.20.51.0.2-5.42.el6.x86_64 is a duplicate with binutils-2.20.51.0.2-5.36.el6.x86_64
chkconfig-1.3.49.3-2.el6_4.1.x86_64 is a duplicate with chkconfig-1.3.49.3-2.el6.x86_64
coreutils-8.4-37.el6.x86_64 is a duplicate with coreutils-8.4-19.el6_4.2.x86_64
coreutils-libs-8.4-37.el6.x86_64 is a duplicate with coreutils-libs-8.4-19.el6_4.2.x86_64
  • Yum update fails due to duplicate package on the system:
tigervnc-server-1.1.0-8.el6_5.x86_64 is a duplicate with tigervnc-server-1.1.0-5.el6_4.1.x86_64
  • The yum command fails with below messages:
file-5.04-6.el6.i686 is a duplicate with file-5.04-5.el6.x86_64
file-libs-5.04-6.el6.i686 is a duplicate with file-libs-5.04-5.el6.x86_64
spiderengine-1.0-4.i386 has missing requires of linux-gate.so.1

Environment

  • Red Hat Enterprise Linux (RHEL) 5, 6, 7
  • yum

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In