Upgrade to RHEV-M 3.3 fails suggesting to run changedbowner.sh script

Solution Verified - Updated -

Issue

  • Under certain circumstances RHEV-M upgrade from 3.2 to 3.3 fails suggesting to run changedbowner.sh script. Another failure to upgrade is achieved as a result of running the script and performing the upgrade process again.
  • RHEV 3.3 upgrade fails with error: "Failed to exec setup validation. Cannot upgrade the database schema due to wrong ownership of some database entities"

    ERROR  Failed to execute stage 'Setup validation': Cannot upgrade the database schema due to wrong ownership of some database entities. Please execute: /usr/share/ovirt-engine/setup/dbutils/changedbowner.sh -s localhost -p 5432 -d engine -f postgres -t engine Using the password of the "postgres" user.
    

Environment

Red Hat Enterprise Virtualization Manager (RHEV-M) 3.2 during upgrade process to 3.3

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In