Why does 'yum update' fails with the error "glibc-static Requires: glibc-devel"?

Solution Verified - Updated -

Issue

  • 'yum update' fails with the following error :-
   Error: Package: glibc-static-2.12-1.107.el6.x86_64 (@rhel-x86_64-server-optional-6/6.3)
           Requires: glibc-devel = 2.12-1.107.el6
           Removing: glibc-devel-2.12-1.107.el6.x86_64 (@rhel-x86_64-server-6)
               glibc-devel = 2.12-1.107.el6

Environment

  • Red Hat Enterprise Linux (RHEL) 6
  • Red Hat Network (RHN)

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In