Getting warning about 'org.eclipse.jgit.api.errors.JGitInternalException: Short read of block'

Solution Unverified - Updated -

Issue

  • Getting warning about org.eclipse.jgit.api.errors.JGitInternalException: Short read of block followed by No profile data yet so cannot update!

    2020-12-16 13:32:00,042 | WARN  | store-2-thread-1 | ZkDataStoreImpl                  | 70 - io.fabric8.fabric-core - 1.2.0.redhat-630475 | Caught: com.google.common.util.concurrent.UncheckedExecutionException: org.eclipse.jgit.api.errors.JGitInternalException: Short read of block.
    com.google.common.util.concurrent.UncheckedExecutionException: org.eclipse.jgit.api.errors.JGitInternalException: Short read of block.
        at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2203)[61:com.google.guava:18.0.0.redhat-1]
        at com.google.common.cache.LocalCache.get(LocalCache.java:3937)[61:com.google.guava:18.0.0.redhat-1]
        at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:3941)[61:com.google.guava:18.0.0.redhat-1]
        at com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:4824)[61:com.google.guava:18.0.0.redhat-1]
        at io.fabric8.git.internal.GitDataStoreImpl.getVersionFromCacheRW(GitDataStoreImpl.java:585)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitDataStoreImpl.getVersionFromCache(GitDataStoreImpl.java:547)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitDataStoreImpl.getVersion(GitDataStoreImpl.java:801)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.internal.ProfileServiceImpl.getVersion(ProfileServiceImpl.java:126)[70:io.fabric8.fabric-core:1.2.0.redhat-630475]
        at io.fabric8.internal.ContainerImpl.getVersion(ContainerImpl.java:199)[70:io.fabric8.fabric-core:1.2.0.redhat-630475]
        at io.fabric8.internal.ContainerImpl.getContainerProfile(ContainerImpl.java:758)[70:io.fabric8.fabric-core:1.2.0.redhat-630475]
        at io.fabric8.internal.ContainerImpl.getOverlayProfile(ContainerImpl.java:302)[70:io.fabric8.fabric-core:1.2.0.redhat-630475]
        at io.fabric8.features.FabricFeaturesServiceImpl.listInstalledRepositories(FabricFeaturesServiceImpl.java:400)[78:io.fabric8.fabric-features-service:1.2.0.redhat-630475]
        at io.fabric8.features.FabricFeaturesServiceImpl.run(FabricFeaturesServiceImpl.java:116)[78:io.fabric8.fabric-features-service:1.2.0.redhat-630475]
        at io.fabric8.service.ZkDataStoreImpl.doRunCallbacks(ZkDataStoreImpl.java:246)[70:io.fabric8.fabric-core:1.2.0.redhat-630475]
        at io.fabric8.service.ZkDataStoreImpl.access$100(ZkDataStoreImpl.java:103)[70:io.fabric8.fabric-core:1.2.0.redhat-630475]
        at io.fabric8.service.ZkDataStoreImpl$1.run(ZkDataStoreImpl.java:234)[70:io.fabric8.fabric-core:1.2.0.redhat-630475]
        at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)[:1.8.0_151]
        at java.util.concurrent.FutureTask.run(Unknown Source)[:1.8.0_151]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)[:1.8.0_151]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)[:1.8.0_151]
        at java.lang.Thread.run(Unknown Source)[:1.8.0_151]
    Caused by: org.eclipse.jgit.api.errors.JGitInternalException: Short read of block.
        at org.eclipse.jgit.api.CheckoutCommand.call(CheckoutCommand.java:320)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitHelpers.checkoutBranch(GitHelpers.java:158)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitDataStoreImpl.checkoutProfileBranch(GitDataStoreImpl.java:1460)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitDataStoreImpl.checkoutRequiredProfileBranch(GitDataStoreImpl.java:1464)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitDataStoreImpl.access$1300(GitDataStoreImpl.java:135)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitDataStoreImpl$VersionCacheLoader.populateVersionBuilder(GitDataStoreImpl.java:2022)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitDataStoreImpl$VersionCacheLoader.loadVersion(GitDataStoreImpl.java:2017)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitDataStoreImpl$VersionCacheLoader.access$3300(GitDataStoreImpl.java:1998)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitDataStoreImpl$VersionCacheLoader$1.call(GitDataStoreImpl.java:2006)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitDataStoreImpl$VersionCacheLoader$1.call(GitDataStoreImpl.java:2003)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitDataStoreImpl.executeInternal(GitDataStoreImpl.java:1206)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitDataStoreImpl.access$2600(GitDataStoreImpl.java:135)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitDataStoreImpl$VersionCacheLoader.load(GitDataStoreImpl.java:2010)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at io.fabric8.git.internal.GitDataStoreImpl$VersionCacheLoader.load(GitDataStoreImpl.java:1998)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3527)[61:com.google.guava:18.0.0.redhat-1]
        at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2319)[61:com.google.guava:18.0.0.redhat-1]
        at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2282)[61:com.google.guava:18.0.0.redhat-1]
        at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2197)[61:com.google.guava:18.0.0.redhat-1]
        ... 20 more
    Caused by: java.io.EOFException: Short read of block.
        at org.eclipse.jgit.util.IO.readFully(IO.java:249)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at org.eclipse.jgit.dircache.DirCache.readFrom(DirCache.java:456)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at org.eclipse.jgit.dircache.DirCache.read(DirCache.java:411)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:227)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:301)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:267)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at org.eclipse.jgit.lib.Repository.lockDirCache(Repository.java:1053)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        at org.eclipse.jgit.api.CheckoutCommand.call(CheckoutCommand.java:257)[72:io.fabric8.fabric-git:1.2.0.redhat-630475]
        ... 37 more
    2020-12-16 13:32:00,073 | WARN  | admin-1-thread-1 | FabricConfigAdminBridge          | 73 - io.fabric8.fabric-configadmin - 1.2.0.redhat-630475 | No profile data yet so cannot update!
    2020-12-16 13:32:00,131 | WARN  | admin-1-thread-1 | FabricConfigAdminBridge          | 73 - io.fabric8.fabric-configadmin - 1.2.0.redhat-630475 | No profile data yet so cannot update!
    2
    

Environment

  • Red Hat Fuse (Fuse)
    • 6.3 R10

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In