Why does installing 'redhat-lsb-core' fails with the dependency error involving 'cups-libs'?

Solution In Progress - Updated -

Issue

  • Installation of redhat-lsb-core cause dependency issue with the below error.
yum install redhat-lsb-core
Loaded plugins: gcs, product-id, search-disabled-repos, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package redhat-lsb-core.x86_64 0:4.1-27.el7 will be installed
--> Processing Dependency: redhat-lsb-submod-security(x86-64) = 4.1-27.el7 for package: redhat-lsb-core-4.1-27.el7.x86_64
--> Processing Dependency: /bin/ed for package: redhat-lsb-core-4.1-27.el7.x86_64
--> Processing Dependency: /usr/bin/at for package: redhat-lsb-core-4.1-27.el7.x86_64
--> Processing Dependency: /usr/bin/batch for package: redhat-lsb-core-4.1-27.el7.x86_64
--> Processing Dependency: /usr/bin/bc for package: redhat-lsb-core-4.1-27.el7.x86_64
--> Processing Dependency: /usr/bin/killall for package: redhat-lsb-core-4.1-27.el7.x86_64
--> Processing Dependency: /usr/bin/lp for package: redhat-lsb-core-4.1-27.el7.x86_64
--> Processing Dependency: /usr/bin/lpr for package: redhat-lsb-core-4.1-27.el7.x86_64
--> Processing Dependency: /usr/bin/time for package: redhat-lsb-core-4.1-27.el7.x86_64
--> Processing Dependency: /usr/sbin/fuser for package: redhat-lsb-core-4.1-27.el7.x86_64
--> Processing Dependency: spax for package: redhat-lsb-core-4.1-27.el7.x86_64
--> Running transaction check
---> Package at.x86_64 0:3.1.13-24.el7 will be installed
---> Package bc.x86_64 0:1.06.95-13.el7 will be installed
---> Package cups-client.x86_64 1:1.6.3-40.el7 will be installed
--> Processing Dependency: cups-libs(x86-64) = 1:1.6.3-40.el7 for package: 1:cups-client-1.6.3-40.el7.x86_64
---> Package ed.x86_64 0:1.9-4.el7 will be installed
---> Package psmisc.x86_64 0:22.20-16.el7 will be installed
---> Package redhat-lsb-submod-security.x86_64 0:4.1-27.el7 will be installed
---> Package spax.x86_64 0:1.5.2-13.el7 will be installed
---> Package time.x86_64 0:1.7-45.el7 will be installed
--> Finished Dependency Resolution
Error: Package: 1:cups-client-1.6.3-40.el7.x86_64 (rhel-7-server-rpms)
           Requires: cups-libs(x86-64) = 1:1.6.3-40.el7
           Installed: 1:cups-libs-1.6.3-43.el7.x86_64 (@rhui-rhel-7-server-rhui-rpms/7Server)
               cups-libs(x86-64) = 1:1.6.3-43.el7
           Available: 1:cups-libs-1.6.3-14.el7.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-14.el7
           Available: 1:cups-libs-1.6.3-17.el7.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-17.el7
           Available: 1:cups-libs-1.6.3-17.el7_1.1.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-17.el7_1.1
           Available: 1:cups-libs-1.6.3-22.el7.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-22.el7
           Available: 1:cups-libs-1.6.3-26.el7.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-26.el7
           Available: 1:cups-libs-1.6.3-29.el7.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-29.el7
           Available: 1:cups-libs-1.6.3-35.el7.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-35.el7
           Available: 1:cups-libs-1.6.3-40.el7.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-40.el7
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: 1:cups-client-1.6.3-40.el7.x86_64 (rhel-7-server-rpms)
           Requires: cups-libs(x86-64) = 1:1.6.3-40.el7
           Installed: 1:cups-libs-1.6.3-43.el7.x86_64 (@rhui-rhel-7-server-rhui-rpms/7Server)
               cups-libs(x86-64) = 1:1.6.3-43.el7
           Available: 1:cups-libs-1.6.3-14.el7.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-14.el7
           Available: 1:cups-libs-1.6.3-17.el7.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-17.el7
           Available: 1:cups-libs-1.6.3-17.el7_1.1.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-17.el7_1.1
           Available: 1:cups-libs-1.6.3-22.el7.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-22.el7
           Available: 1:cups-libs-1.6.3-26.el7.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-26.el7
           Available: 1:cups-libs-1.6.3-29.el7.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-29.el7
           Available: 1:cups-libs-1.6.3-35.el7.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-35.el7
           Available: 1:cups-libs-1.6.3-40.el7.x86_64 (rhel-7-server-rpms)
               cups-libs(x86-64) = 1:1.6.3-40.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Environment

  • Red Hat Enterprise Linux 7.

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In