Why yum is installing exim,mysql,perl-DBI packages as dependencies of package redhat-lsb for some system ?

Solution Verified - Updated -

Issue

  • The redhat-lsb is showing dependency for exim,mysql,perl-DBI packages on some systems only, on other systems these dependencies are not shown.

  • Odd package dependency behaviour when trying to install redhat-lsb package,

Dependencies Resolved

=================================================================================================================================
Package                 Arch                Version                       Repository                                       Size
=================================================================================================================================
Installing:
redhat-lsb              i386                4.0-2.1.4.el5                 clone-aligned-rhel-x86_64-server-5               25 k
redhat-lsb              x86_64              4.0-2.1.4.el5                 clone-aligned-rhel-x86_64-server-5               24 k
Installing for dependencies:
exim                    x86_64              4.63-10.el5                   clone-aligned-rhel-x86_64-server-5              1.2 M
mysql                   x86_64              5.0.95-3.el5                  clone-aligned-rhel-x86_64-server-5              4.9 M
perl-DBI                x86_64              1.52-2.el5                    clone-aligned-rhel-x86_64-server-5              605 k

Transaction Summary
=================================================================================================================================
Install       5 Package(s)
Upgrade       0 Package(s)

Total download size: 6.8 M
Is this ok [y/N]: N
Exiting on user Command
Complete!

Environment

  • Red Hat Enterprise Linux 5

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In