How do I Fix "A compliant Ansible Tower license is required to upgrade" when Running setup.sh for Ansible Tower?

Solution Verified - Updated -

Issue

  • A preflight check for the Ansible Tower license fails when attempting to re-run setup.sh after reinstall
  • Troubleshooting issues with the installer for an upgrade to 3.6+ resulted in an unexpected preflight license error

Environment

Ansible Tower >= 3.6

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In