Openstack overcloud baremetal deploy fails with API version error

Solution In Progress - Updated -

Issue

  • When running sudo openstack overcloud node provision --stack stack --output ~/overcloud-baremetal-deployed.yaml ~/overcloud-baremetal-deploy.yaml, the following error is returned:
Error deploying nodes: {'result': "Failure caused by error in tasks: send_message\n\n  send_message [task_ex_id=9f7fab46-feee-4bae-b88d-c88d25fed2ef] -> Workflow failed due to message status. Status:FAILED Message:({'result': 'DeploymentFailed: API version 1.56 is required, but 1.52 will be used.'}, {'result': 'DeploymentFailed: API version 1.56 is required, but 1.52 will be used.'}, {'result': 'DeploymentFailed: API version 1.56 is required, but 1.52 will be used.'}, {'result': 'DeploymentFailed: API version 1.56 is required, but 1.52 will be used.'}, {'result': [...]

Environment

  • Red Hat OpenStack Platform 16.0 (RHOSP)

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In