Red Hat Satelite upgrade to version 6.7 fails with error You cannot specify the same gem twice with different version requirements. (Bundler::GemfileError)

Solution Verified - Updated -

Issue

  • Upgrading Red Hat Satellite or Red Hat Capsule to version 6.7 fails with below error:

    [ERROR 2020-01-01T20:00:00 main] Jan 01 20:00:00 satellite.example.com smart-proxy[117673]: /usr/share/foreman-proxy/Gemfile.in:12:in `instance_eval': You cannot specify the same gem twice with different version requirements. (Bundler::GemfileError)
    [ERROR 2020-01-01T20:00:00 main] Jan 01 20:00:00 satellite.example.com smart-proxy[117673]: You specified: rsec (< 1) and rsec (>= 0)
    
    

Environment

  • Red Hat Satellite 6.7
  • Red Hat Capsule 6.7

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In