RPM upgrade issue while upgrading RHSSO 7

Solution Verified - Updated -

Issue

  • Following the documentation link and facing the following error when executing yum upgrade in the last step:

    Error: Package: rh-sso7-keycloak-server-4.8.20-1.Final_redhat_00001.1.el7sso.noarch (@rh-sso-7.3-for-rhel-7-server-rpms)
               Requires: eap7-wildfly-modules = 7.2.8
               Removing: eap7-wildfly-modules-7.2.8-3.GA_redhat_00002.1.el7eap.noarch (@jb-eap-7.2-for-rhel-7-server-rpms)
                   eap7-wildfly-modules = 7.2.8-3.GA_redhat_00002.1.el7eap
               Updated By: eap7-wildfly-modules-7.3.1-5.GA_redhat_00003.1.el7eap.noarch (jb-eap-7.3-for-rhel-7-server-rpms)
                   eap7-wildfly-modules = 7.3.1-5.GA_redhat_00003.1.el7eap
               Available: eap7-wildfly-modules-7.2.0-31.GA_redhat_00005.1.el7eap.noarch (jb-eap-7.3-for-rhel-7-server-rpms)
                   eap7-wildfly-modules = 7.2.0-31.GA_redhat_00005.1.el7eap
               Available: eap7-wildfly-modules-7.2.1-6.GA_redhat_00004.1.el7eap.noarch (jb-eap-7.3-for-rhel-7-server-rpms)
                   eap7-wildfly-modules = 7.2.1-6.GA_redhat_00004.1.el7eap
               Available: eap7-wildfly-modules-7.2.2-2.GA_redhat_00001.1.el7eap.noarch (jb-eap-7.3-for-rhel-7-server-rpms)
                   eap7-wildfly-modules = 7.2.2-2.GA_redhat_00001.1.el7eap
               Available: eap7-wildfly-modules-7.2.3-3.GA_redhat_00003.1.el7eap.noarch (jb-eap-7.3-for-rhel-7-server-rpms)
                   eap7-wildfly-modules = 7.2.3-3.GA_redhat_00003.1.el7eap
               Available: eap7-wildfly-modules-7.2.4-1.GA_redhat_00002.1.el7eap.noarch (jb-eap-7.3-for-rhel-7-server-rpms)
                   eap7-wildfly-modules = 7.2.4-1.GA_redhat_00002.1.el7eap
               Available: eap7-wildfly-modules-7.2.4-2.SP1_redhat_00001.1.el7eap.noarch (jb-eap-7.3-for-rhel-7-server-rpms)
                   eap7-wildfly-modules = 7.2.4-2.SP1_redhat_00001.1.el7eap
               Available: eap7-wildfly-modules-7.2.5-4.GA_redhat_00002.1.el7eap.noarch (jb-eap-7.3-for-rhel-7-server-rpms)
                   eap7-wildfly-modules = 7.2.5-4.GA_redhat_00002.1.el7eap
               Available: eap7-wildfly-modules-7.2.6-5.GA_redhat_00001.1.el7eap.noarch (jb-eap-7.3-for-rhel-7-server-rpms)
                   eap7-wildfly-modules = 7.2.6-5.GA_redhat_00001.1.el7eap
               Available: eap7-wildfly-modules-7.3.0-22.GA_redhat_00004.1.el7eap.noarch (jb-eap-7.3-for-rhel-7-server-rpms)
                   eap7-wildfly-modules = 7.3.0-22.GA_redhat_00004.1.el7eap
            ...
    
  • Problems updating from SSO 7.3.3 to 7.3.8

    # dnf update
    Updating Subscription Management repositories.
    Single Sign-On 7.3 for RHEL 8 x86_64 (RPMs)                                                                                                        75 kB/s | 101 kB     00:01
    JBoss Enterprise Application Platform 7.2 (RHEL 8) (RPMs)                                                                                         3.4 MB/s | 4.1 MB     00:01
    Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs)                                                                                           18 kB/s | 4.5 kB     00:00
    Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs)                                                                                              16 kB/s | 4.1 kB     00:00
    Error:
     Problem: package rh-sso7-keycloak-server-4.8.20-1.Final_redhat_00001.1.el8sso.noarch requires eap7-wildfly-modules = 7.2.8, but none of the providers can be installed
      - cannot install both eap7-wildfly-modules-7.2.9-4.GA_redhat_00003.1.el8eap.noarch and eap7-wildfly-modules-7.2.8-3.GA_redhat_00002.1.el8eap.noarch
      - cannot install both eap7-wildfly-modules-7.2.9-4.GA_redhat_00003.1.el8eap.noarch and eap7-wildfly-modules-7.2.8-6.GA_redhat_00003.1.el8eap.noarch
      - cannot install the best update candidate for package rh-sso7-keycloak-server-4.8.11-2.Final_redhat_00001.1.el8sso.noarch
      - cannot install the best update candidate for package eap7-wildfly-modules-7.2.3-3.GA_redhat_00003.1.el8eap.noarch
    (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
    

Environment

  • Red Hat Single Sign-On (RHSSO)
    • 7
  • Red Hat Enterprise Linux (RHEL)
    • 7
    • 8
  • Running RH-SSO in RPM mode

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In