Pod Disruption Budget (PDB) alerts are continuously firing for ceph-osd pods when OCS 4.x is deployed on OCP v4.3 or above.

Solution Verified - Updated -

Issue

  • The following alert is seen after upgrading OCP to 4.3 or deploying a fresh OCS 4.x cluster on OCP 4.3 for ceph-osd pods.

    The pod disruption budget is preventing further disruption to pods because it is at the minimum allowed level.
    

Environment

  • OpenShift Container Platform 4.3 or above
  • Red Hat OpenShift Container Storage 4.x

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In

New to Red Hat?

Learn more about Red Hat subscriptions

Using a Red Hat product through a public cloud?

How to access this content