Satellite upgrade 6.3 -> 6.4 fails with '/opt/puppetlabs/puppet/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- kafo (LoadError)'

Solution Verified - Updated -

Issue

While upgrading Satellite 6.3 -> 6.4, it fails with below error:

D, [2019-05-24 11:58:17+0200 #28527] DEBUG -- : output of the command:
 Script started on Fri 24 May 2019 11:58:17 AM CEST
/opt/puppetlabs/puppet/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- kafo (LoadError)^M
        from /opt/puppetlabs/puppet/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'^M
        from /sbin/satellite-installer:3:in `<main>'^M

Environment

Satellite

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In