Failed to upgrade OCP from 3.10 to 3.11 with error: 'docker: network plugin is not ready: cni config uninitialized'

Solution Verified - Updated -

Issue

  • Upgrading OCP 3.10 to 3.11 fails, OVS and SDN pods are with status crashing.

Environment

  • Red Hat OpenShift Container Platform (OCP) 3.10
  • Red Hat OpenShift Container Platform (OCP) 3.11

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In