Error running "yum update" with Red Hat Single Sign-On during the period between Red Hat JBoss Enterprise Application Platform (EAP) and Red Hat Single Sign-On upgrade (RHSA) being available

Solution Unverified - Updated -

Issue

  • Error running yum update with Red Hat Single Sign-On which shows a requirement for a specific version of EAP but also shows that version is being removed which is an error:
Error: Package: rh-sso7-keycloak-server-4.8.11-1.Final_redhat_00001.1.el7sso.noarch (@rh-sso-7.3-for-rhel-7-server-rpms)
Requires: eap7-wildfly-modules = 7.2.3
Removing: eap7-wildfly-modules-7.2.3-3.GA_redhat_00003.1.el7eap.noarch (@jb-eap-7.2-for-rhel-7-server-rpms)
eap7-wildfly-modules = 7.2.3-3.GA_redhat_00003.1.el7eap
Updated By: eap7-wildfly-modules-7.2.4-1.GA_redhat_00002.1.el7eap.noarch (jb-eap-7.2-for-rhel-7-server-rpms)
eap7-wildfly-modules = 7.2.4-1.GA_redhat_00002.1.el7eap

Environment

  • Red Hat Single Sign-On installed from RPM

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In