Satellite 5.4 Upgrade does not carry over HTTP Proxy settings

Solution Verified - Updated -

Issue

  • We just upgraded both our satellite servers from 5.3 to 5.4.  The upgrade went smoothly, except the HTTP Proxy does not get carried over.
  • For a connected satellite, it means the activation step (step 4 in /etc/sysconfig/rhn/satellite-upgrade/satellite-upgrade.txt) fails.
  • I am referring to this line in /etc/rhn/rhn.conf:

    server.satellite.http_proxy = my.proxy.com:port
    
  • Obviously this is easy to work around, but this setting gets clobbered twice during the update.  First during the upgrade (step 1) and then again in step 7 or 8 (not sure which one).

  • Upgrading satellite does not change my need (or lack thereof) for a HTTP Proxy, so that setting should carry over as part of the upgrade process.

Environment

  • Satellite 5.4, upgraded from Satellite 5.3

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In