There are issues with remote ejb-client invocations which should be solved in this version

Solution Verified - Updated -

Environment

  • JBoss Enterprise Application Platform (EAP) 6.x

Issue

  • Although a new EAP6 server version is installed, which should solve the issues, there are still the same problems with remote ejb-client invocations
  • I found a bug which should be solved in the EAP version I use, but I still see the issue if I invoke EJB's remote
  • The client hung up or throw an Exception which points me to an issue that seems resolved in the used version
  • It is not possible to invoke EJB remotely, but the code looks correct and if an old server version is connected it worked
  • I have weird behaviour if I invoke EJB's from a standalone client

Resolution

  • A standalone Java application should use the correct jboss-client.jar which is provided in the JBOSS_HOME/bin/client directory
  • If it is a test environment, i.e. maven, ensure that all necessary libraries (xnio, remoting, ejb-client), set by dependencies, are suitable for the connected server

If there are issues, it is recommended that the appropriate JBoss EAP 6 component details are used.

Also refer to the Best practices for JBoss EAP patches

Root Cause

As the client uses different libraries to manage the client context, and establish the connection, it might happen that different versions are not compatible.
Also bugs might be fixed in that libraries and it is necessary to have the fix on the server side, the client side or on both sides.

Diagnostic Steps

  • check the client side whether the appropriate versions are installed
    • check that the jboss-client.jar is the same as the one provided by the server
    • check maven dependencies if the client is diven by maven

The different libraries are logged at INFO level during client initialization.
The appropriate versions are listed in the component details

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