Yum dependency error while trying to upgrade or install Red Hat Satellite 6.5

Solution Verified - Updated -

Issue

  • When installing or upgrading to Red Hat Satellite 6.5 some external RPM dependencies prevent upgrade due to a dependency loop:

    # yum install satellite-common-6.5.0-11.el7sat.noarch
    ...
    Error: Package: rh-ruby24-rubygems-2.6.14.4-92.el7.noarch (rhel-server-rhscl-7-rpms)
       Requires: rh-ruby24-runtime
       Removing: rh-ruby24-runtime-2.4-2.el7.x86_64 (@rhel-server-rhscl-7-rpms)
           rh-ruby24-runtime = 2.4-2.el7
       Obsoleted By: satellite-common-6.5.0-11.el7sat.noarch (rhel-7-server-satellite-6.5-rpms)
           Not found
    Error: Package: rh-ruby24-rubygem-io-console-0.4.6-92.el7.x86_64 (rhel-server-rhscl-7-rpms)
       Requires: rh-ruby24-runtime
       Removing: rh-ruby24-runtime-2.4-2.el7.x86_64 (@rhel-server-rhscl-7-rpms)
           rh-ruby24-runtime = 2.4-2.el7
       Obsoleted By: satellite-common-6.5.0-11.el7sat.noarch (rhel-7-server-satellite-6.5-rpms)
           Not found
    ...
    

Environment

  • Red Hat Satellite 6.5

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In