Older 3.11 versions of the oc client do not work on RHEL8, Fedora 30, Ubuntu and other Debian based distributions

Solution Unverified - Updated -

Issue

  • OpenShift oc client versions 3.11.x earlier than 3.11.117 do not work on RHEL8, Fedora 30, Ubuntu and other Debian based distributions.
  • When using oc tool fails with error:
oc: error while loading shared libraries: libcrypto.so.10: cannot open shared object file: No such file or directory
  • The following error message is displayed:
oc: /usr/lib/x86_64-linux-gnu/libcrypto.so.10: version `OPENSSL_1.0.1_EC' not found (required by oc)

Environment

  • Red Hat OpenShift Container Platform (OCP) 3.11
  • Red Hat Enterprise Linux (RHEL) 8

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In