Getting ixgbe errors on screen and X is freezing after migrating the system from Red Hat Enterprise Linux 5 to 6.

Solution Unverified - Updated -

Issue

  • Getting ixgbe errors mentioned below on screen and X is also freezing after migrating the system from Red Hat Enterprise Linux 5 to 6.
WARNING: at net/core/dev.c:1760 skb_gso_segment+0x1df/0x2b0() (Tainted: P        W  ---------------   )
Hardware name: Precision WorkStation R5500  
ixgbe: caps=(0x3b31cbb3, 0x0) len=1500 data_len=1448 ip_summed=1
Modules linked in: autofs4 vmnet(U) ppdev parport_pc parport fuse vsock(U) vmci(U) vmmon(U) rpcsec_gss_krb5 auth_rpcgss sunrpc ipv6 vhost_net macvtap macvlan tun kvm_intel kvm uinput ixgbe dca ptp pps_core mdio pcoip_host(U) nvidia(P)(U) sg dcdbas microcode serio_raw i2c_i801 i2c_core iTCO_wdt iTCO_vendor_support snd_hda_codec_realtek snd_hda_codec_hdmi snd_hda_codec_analog snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc i7core_edac edac_core shpchp ext4 mbcache jbd2 sd_mod crc_t10dif mptsas mptscsih mptbase scsi_transport_sas sr_mod cdrom usb_storage ahci wmi dm_mirror dm_region_hash dm_log dm_mod [last unloaded: speedstep_lib]
Pid: 0, comm: swapper Tainted: P        W  ---------------    2.6.32-358.2.1.el6.x86_64 #1
Call Trace:
 <IRQ>  [<ffffffff8106e2e7>] ? warn_slowpath_common+0x87/0xc0
 [<ffffffff8106e3d6>] ? warn_slowpath_fmt+0x46/0x50
 [<ffffffffa0b55808>] ? ixgbe_get_drvinfo+0x98/0xd0 [ixgbe]
 [<ffffffff8144898f>] ? skb_gso_segment+0x1df/0x2b0
 [<ffffffffa0d990ae>] ? VNetBridgeSendLargePacket+0x1a/0x8c [vmnet]
 [<ffffffffa0d9a315>] ? VNetBridgeReceiveFromDev+0x369/0x394 [vmnet]
 [<ffffffff814480ee>] ? __netif_receive_skb+0x1de/0x750
 [<ffffffff8144a798>] ? netif_receive_skb+0x58/0x60
 [<ffffffff8144a8a0>] ? napi_skb_finish+0x50/0x70
 [<ffffffff8144ce49>] ? napi_gro_receive+0x39/0x50
 [<ffffffffa0b4644c>] ? ixgbe_poll+0xa6c/0x1280 [ixgbe]
 [<ffffffff810e3e28>] ? handle_edge_irq+0x98/0x180
 [<ffffffff8144cf63>] ? net_rx_action+0x103/0x2f0
 [<ffffffff81076fb1>] ? __do_softirq+0xc1/0x1e0
 [<ffffffff8109b77b>] ? hrtimer_interrupt+0x14b/0x260
 [<ffffffff8100c1cc>] ? call_softirq+0x1c/0x30
 [<ffffffff8100de05>] ? do_softirq+0x65/0xa0
 [<ffffffff81076d95>] ? irq_exit+0x85/0x90
 [<ffffffff81517000>] ? smp_apic_timer_interrupt+0x70/0x9b
 [<ffffffff8100bb93>] ? apic_timer_interrupt+0x13/0x20
 <EOI>  [<ffffffff812d397e>] ? intel_idle+0xde/0x170
 [<ffffffff812d3961>] ? intel_idle+0xc1/0x170
 [<ffffffff8109dd3d>] ? sched_clock_cpu+0xcd/0x110
 [<ffffffff81415117>] ? cpuidle_idle_call+0xa7/0x140
 [<ffffffff81009fc6>] ? cpu_idle+0xb6/0x110
 [<ffffffff81506d9c>] ? start_secondary+0x2ac/0x2ef
  • There are also issues with the parts of the screen changing colour, parts of the screen not updating, mouse hanging.

  • Also network connection going up and down.

Environment

  • Red Hat Enterprise Linux 6.4
  • NVIDIA Quadro 6000 graphics
  • Vmware Hypervisor

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In