Error while trying to install Tivoli Storage Manager

Solution Verified - Updated -

Issue

  • Unable to install "IBM Tivoli" due to following dependency issues :-
# rpm -ivh TIVsm-BAcit.x86_64.rpm
error: Failed dependencies:
        TIVsm-BA = 6.3.0-0 is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libc.so.6 is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libc.so.6(GLIBC_2.0) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libc.so.6(GLIBC_2.1) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libc.so.6(GLIBC_2.1.3) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libc.so.6(GLIBC_2.2) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libc.so.6(GLIBC_2.3) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libc.so.6(GLIBC_2.3.2) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libdl.so.2 is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libdl.so.2(GLIBC_2.0) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libdl.so.2(GLIBC_2.1) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libgcc_s.so.1 is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libgcc_s.so.1(GCC_3.0) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libgcc_s.so.1(GLIBC_2.0) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libm.so.6 is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libnsl.so.1 is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libpthread.so.0 is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libpthread.so.0(GLIBC_2.0) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libpthread.so.0(GLIBC_2.1) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libpthread.so.0(GLIBC_2.2) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libpthread.so.0(GLIBC_2.3.2) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libstdc++.so.5 is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libstdc++.so.5(CXXABI_1.2) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libstdc++.so.5(GLIBCPP_3.2) is needed by TIVsm-BAcit-6.3.0-0.x86_64
        libstdc++.so.5(GLIBCPP_3.2.2) is needed by TIVsm-BAcit-6.3.0-0.x86_64
root@paz1apil1v(/home/qcpuf36j)# rpm -ivh glibc-2.12-1.80.el6_3.6.i686.rpm
warning: glibc-2.12-1.80.el6_3.6.i686.rpm: Header V3 RSA/SHA256 Signature, key ID fd431d51: NOKEY
error: Failed dependencies:
        glibc-common = 2.12-1.80.el6_3.6 is needed by glibc-2.12-1.80.el6_3.6.i686
        libfreebl3.so is needed by glibc-2.12-1.80.el6_3.6.i686
        libfreebl3.so(NSSRAWHASH_3.12.3) is needed by glibc-2.12-1.80.el6_3.6.i686
root@paz1apil1v(/home/qcpuf36j)# rpm -ivh glibc-common-2.12-1.80.el6_3.6.i686.rpm
warning: glibc-common-2.12-1.80.el6_3.6.i686.rpm: Header V3 RSA/SHA256 Signature, key ID fd431d51: NOKEY
error: Failed dependencies:
        glibc = 2.12-1.80.el6_3.6 is needed by glibc-common-2.12-1.80.el6_3.6.i686
        libc.so.6 is needed by glibc-common-2.12-1.80.el6_3.6.i686
        libc.so.6(GLIBC_2.0) is needed by glibc-common-2.12-1.80.el6_3.6.i686
        libc.so.6(GLIBC_2.1) is needed by glibc-common-2.12-1.80.el6_3.6.i686
        libc.so.6(GLIBC_2.1.1) is needed by glibc-common-2.12-1.80.el6_3.6.i686
        libc.so.6(GLIBC_2.1.3) is needed by glibc-common-2.12-1.80.el6_3.6.i686
        libc.so.6(GLIBC_2.10) is needed by glibc-common-2.12-1.80.el6_3.6.i686
        libc.so.6(GLIBC_2.2) is needed by glibc-common-2.12-1.80.el6_3.6.i686
        libc.so.6(GLIBC_2.3) is needed by glibc-common-2.12-1.80.el6_3.6.i686
        libcap.so.2 is needed by glibc-common-2.12-1.80.el6_3.6.i686
        libdl.so.2 is needed by glibc-common-2.12-1.80.el6_3.6.i686
        libdl.so.2(GLIBC_2.0) is needed by glibc-common-2.12-1.80.el6_3.6.i686
        libdl.so.2(GLIBC_2.1) is needed by glibc-common-2.12-1.80.el6_3.6.i686
  • libc.so.6 dependency for TIVsm-BA.x86_64.rpm even though the libc.so.6 and glibc are present in the server :-
# rpm -ivh TIVsm-BA.x86_64.rpm
error: Failed dependencies:
        libc.so.6 is needed by TIVsm-BA-6.3.0-0.x86_64

# ls -lrt | grep -i libc.so.6
 libc.so.6 -> libc-2.12.so

Environment

  • Red Hat Enterprise Linux(RHEL) 6.3

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In