How do you change the default timeout values for a clustered resource in RHEL?

Solution Verified - Updated -

Environment

  • Red Hat Enterprise Linux Server 5 (with the High Availability or Resilient Storage Add-ons)
  • Red Hat Enterprise Linux Server 6 (with the High Availability or Resilient Storage Add-ons)

Issue

  • How do you change the default timeout values for a clustered resource?
  • Some services are staying in the 'starting' state and cannot start correctly.
  • The virtual machine managed by my vm resource is being prematurely killed when stopping when it is slow to shut down

Resolution

For clusters using rgmanager

In order to change the a timeout for start, stop, or status then the option __enforce_timeouts must be set to 1 on that clustered resource. The particular action timeouts can be set on the resource and will be enforced.

The start and stop operations on vm resources will use the default timeouts even if __enforce_timeouts is enabled.

For example:

<script name="foo" file="/scripts/foo.sh" __enforce_timeouts="1">
   <action name="stop" timeout="300" />
   <action name="status" depth="*" timeout="300" />
   <action name="start" timeout="300" />
 </script>

Please note if a timeout is exceeded, then it is considered a failure for that action. This will result in a failure of the service(unless __independent_subtree or other option is set).

NOTE: For more information on modifying resources then please see the article: How often does RHEL High Availability check the status of resources in a clustered service?.

For clusters using pacemaker

For Pacemaker resources, you can change or unset the timeout value and other options for each resource, or the global default values for all resources. For more information see the following:

Root Cause

  • The action (start,stop,status) hangs somewhere and prevents the clustered resource manager rgmanager from completing the action.

This solution is part of Red Hat’s fast-track publication program, providing a huge library of solutions that Red Hat engineers have created while supporting our customers. To give you the knowledge you need the instant it becomes available, these articles may be presented in a raw and unedited form.

Comments