Not able to use satellite-tools v6.3 (with or with PUPPET 4) when using VDC subscriptions

Solution Verified - Updated -

Issue

  • When using VDC subscriptions the Red Hat Satellite tools repositories not enabled at system install time
  • The only way I have been able to (temporarly) get around this is to clone the subscription_manager_register snippet to explicitly enable a satellite-tools repository
  • I then have to clone the Satellite Kickstart Default template to use the cloned snippet above and then modify the OS settings to use the cloned template.

Environment

  • Satellite 6.3
  • Virtual Datacenter Subscription

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase, tools, and much more.

Current Customers and Partners

Log in for full access

Log In